Bug 252972 - Firefox crashes when trying to copy text
Summary: Firefox crashes when trying to copy text
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: 7
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-16 12:43 UTC by Radek Brich
Modified: 2009-06-01 09:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 11:05:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evil page (205 bytes, text/html)
2007-08-16 12:43 UTC, Radek Brich
no flags Details

Description Radek Brich 2007-08-16 12:43:16 UTC
Description of problem:
Firefox crashes with SIGSEGV when trying to copy text from certain page.

Version-Release number of selected component (if applicable):
firefox-2.0.0.5-1.fc7

How reproducible:
always

Steps to Reproduce:
1. save attached html to a file
2. open in Firefox
3. try to copy the text
  
Actual results:
firefox quits promptly

Expected results:
firefox stays alive and allows marking and copying of text

Additional info:
I cut all junk from original page until I got only one div with this style set:
    letter-spacing: 0.05em;
    font-variant: small-caps;

This combination seems to be lethal for Firefox.
Probably bug in font rendering?

Comment 1 Radek Brich 2007-08-16 12:43:16 UTC
Created attachment 161647 [details]
evil page

Comment 2 Radek Brich 2007-10-29 11:05:52 UTC
this was same problem as bug #334141 and is now fixed...

Comment 3 tony 2009-06-01 09:37:51 UTC
This bug is not fixed. It's June 2009 and it happens to me when I copy plain text contained in emails displayed in my Webmail account.

Comment 4 tony 2009-06-01 09:41:12 UTC
This bug is not fixed. It's June 2009 and it happens to me when I copy plain text contained in emails displayed in my Webmail account.


Note You need to log in before you can comment on or make changes to this bug.