Bug 252976 - FreeNX: Request version bump to 0.7.0
FreeNX: Request version bump to 0.7.0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freenx (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
http://freenx.berlios.de/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-16 08:59 EDT by Christian Mandery
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.7.0-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 12:54:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New RPM (63.01 KB, application/x-redhat-package-manager)
2007-09-06 05:51 EDT, Christian Mandery
no flags Details
RPM diff. (1.02 KB, patch)
2007-09-06 05:52 EDT, Christian Mandery
no flags Details | Diff

  None (edit)
Description Christian Mandery 2007-08-16 08:59:29 EDT
Description of problem:
Fedora includes only the 0.6.0 version of FreeNX which has some annoying bugs
(see changelog below). If possible, Fedora should include the new 0.7.0 version.


Additional info:

Changelog:

07.07.2007 FreeNX 0.7.0 "Jornade SPL Edition VI+1"
        * Fixed the printing support for CUPS 1.2.
          Older versions of CUPS are no longer supported.
          * Note: You must do as root:

                  cp /usr/lib/cups/backend/ipp /usr/lib/cups/backend/nxipp
                  chmod 755 /usr/lib/cups/backend/nxipp

                  Or alternatively re-run nxsetup.

        * Added foomatic support.
          * Note: You might need to do: ln -s /usr/bin/foomatic-ppdfile
                  /usr/lib/cups/driver/
        * Added setting of CUPS_SERVER environment var.
        * Added automatic downloading of PPDs, if the client supports it.
        * Added configuration vars to tweak the new behaviour.
        * Added cups seamless support with no "use this driver?" dialogs at all.
          * Note: You need nxcupsd-wrapper on the client side for CUPS 1.2
                  clients.

                  Get it from nxutils repository.

        * Fixed Support for "Running" sessions - again.
        * Made the NXAgent exited with exit code 1 message more verbose.
        * Added support for nxipp to nxnode and nxsetup.
        * Added nxcups-gethost script for automatic usage in KDE.
        * Fixed RDP/VNC sessions. No application should be started for that type.
          (Patch by Bernard Cafarelli )
        * Added backingstore fix for older clients from Gentoo.
          (http://bugs.gentoo.org/show_bug.cgi?id=149298)
        * Fixed VNC sessions.
        * Fixed fullscreen sessions.
          (Patch by Gentoo Bugtracker)
        * Fixed --broadcast.
        * Added "passwd -u nx" to nxsetup to fix slackware.
        * Fixed respecting of enconding settings in case of rootless mode.
        * Fixed smb mounting in case nxclient sends the wrong port.
          (Patch by Jan Lockenvitz )
        * Fixed loadbalancing - was still using an undocumented variable.
Comment 1 Christian Mandery 2007-09-06 05:51:28 EDT
I updated Fedora's 0.6.0 RPM to the latest FreeNX release and added fixes for
two other minor glitches to the RPM.
Comment 2 Christian Mandery 2007-09-06 05:51:49 EDT
Created attachment 188571 [details]
New RPM
Comment 3 Christian Mandery 2007-09-06 05:52:20 EDT
Created attachment 188581 [details]
RPM diff.
Comment 4 Jon Ciesla 2007-09-06 13:28:23 EDT
Axel, are there any technical reasons for me not to commit and build this?
Comment 5 Jon Ciesla 2007-09-06 13:45:50 EDT
To clarify, by "this", I mean a version with sources from upstream and a spec
modified to include Christian's changes (and changelog), built locally and then
mock-tested? :)
Comment 6 Jon Ciesla 2007-09-06 14:07:19 EDT
I've got "this" ready to go.  Should we do anything about the cups backend
change, or simply include the Changelog in the Bohdi update and leave it to
users to fix?  Since freenx doesn't require cups, I don't see that there's any
robust way for the freenx package to fix it.
Comment 7 Jon Ciesla 2007-09-06 14:11:03 EDT
Also, Axel, have you tried out the 3.0.0 nx libs yet?  Not sure if they work
with freenx 0.7.0, or what, just curious.
Comment 8 Jon Ciesla 2007-09-07 07:30:16 EDT
Duh, you're on vacation till Monday 9/10.  /me smacks /me on forehead
I've been using this since yesterday, it works great, I'll commit and build for
rawhide, and possibly through into updates-testing.
Comment 9 Christian Mandery 2007-09-07 07:42:33 EDT
Thanks for your fast response.

Great!
Comment 10 Jon Ciesla 2007-09-07 07:55:09 EDT
No problem.

Built in rawhide and f7.  Bodhi request for push to updates-testing has been
done, including CUPS notes.
Comment 11 Fedora Update System 2007-09-07 13:17:51 EDT
freenx-0.7.0-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Jon Ciesla 2007-09-09 12:34:15 EDT
It seems more than Ok, so I'm pushing to stable.
Comment 13 Fedora Update System 2007-09-10 12:54:01 EDT
freenx-0.7.0-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.