Bug 252983 - udev-113-10 breaks firmware loading
Summary: udev-113-10 breaks firmware loading
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 253041 253042 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-16 13:30 UTC by Sammy
Modified: 2007-11-30 22:12 UTC (History)
4 users (show)

Fixed In Version: 113-11.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-19 15:16:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2007-08-16 13:30:43 UTC
After updating my ipw2200 stopped working due to not being able to load
the firmware. I rebooted a numnber of times with the same result.
Downgrading to udev-113-9 solves the problem. The error messages are:

=====================================================================
Aug 16 08:09:49 a116175 kernel: ipw2200: Intel(R) PRO/Wireless 2200/2915 Network
Driver, 1.2.2kmprq
Aug 16 08:09:49 a116175 kernel: ipw2200: Copyright(c) 2003-2006 Intel Corporation
Aug 16 08:09:49 a116175 kernel: ACPI: PCI Interrupt 0000:02:02.0[A] -> Link
[LNKC] -> GSI 11 (level,
 low) -> IRQ 11
Aug 16 08:09:49 a116175 kernel: ipw2200: Detected Intel PRO/Wireless 2200BG
Network Connection
Aug 16 08:09:49 a116175 kernel: intel_rng: FWH not detected
Aug 16 08:09:49 a116175 kernel: ipw2200: ipw2200-bss.fw request_firmware failed:
Reason -2
Aug 16 08:09:49 a116175 kernel: ipw2200: Unable to load firmware: -2
Aug 16 08:09:49 a116175 kernel: ipw2200: failed to register network device
Aug 16 08:09:49 a116175 kernel: ACPI: PCI interrupt for device 0000:02:02.0 disabled
Aug 16 08:09:49 a116175 kernel: ipw2200: probe of 0000:02:02.0 failed with error -5
Aug 16 08:09:49 a116175 kernel: ACPI: PCI Interrupt 0000:00:1f.5[B] -> Link
[LNKB] -> GSI 11 (level,
==============================================================================

Comment 1 Rex Dieter 2007-08-16 15:36:51 UTC
ditto for iwlwifi firmware not loading, confirmed udev-113-11.fc7 fixes.

Comment 2 John W. Linville 2007-08-17 13:57:04 UTC
*** Bug 253041 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2007-08-17 16:12:05 UTC
udev-113-11.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Matthias Saou 2007-08-17 16:55:29 UTC
Same problem on my laptop with ipw2200, and 113-11.fc7 fixes it for me too.

Comment 5 Fedora Update System 2007-08-19 15:16:21 UTC
udev-113-11.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Matthias Saou 2007-08-19 15:27:34 UTC
*** Bug 253042 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.