Bug 253031 - back button in tui of rhn_register causes Invalid ORG_ID requested error
back button in tui of rhn_register causes Invalid ORG_ID requested error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.0
All Linux
low Severity low
: rc
: ---
Assigned To: Justin Sherrill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-16 13:33 EDT by Jesus M. Rodriguez
Modified: 2008-05-21 12:50 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0362
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:50:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesus M. Rodriguez 2007-08-16 13:33:38 EDT
While testing bug #233067 we found the following scenario
would cause the Invalid ORG_ID error.

1. rhn_register tui
2. On the login screen use and existing user/password.
3. Click next.
4. Click back on this screen.
5. enter a different login and click next.
Observe the error.

[root@rlx-3-08 ~]# rhn_register
An error has occurred:

Error Class Code: 42
Error Class Info: Invalid ORG_ID requested
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

See /var/log/up2date for more information
Comment 1 RHEL Product and Program Management 2007-10-15 23:47:59 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Red Hat Bugzilla 2007-10-25 20:53:14 EDT
User jslagle@redhat.com's account has been closed
Comment 3 RHEL Product and Program Management 2007-11-02 21:35:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Justin Sherrill 2007-12-06 11:17:41 EST
fixed in rev 134551.
Comment 6 Cameron Meadors 2008-02-14 11:59:12 EST
The "Back" button is now greyed out so I cannot go back as the original comment
says.  Is that the fix for this?
Comment 7 David Kovalsky 2008-04-14 08:58:47 EDT
I'm trying to test this, but I don't see the back button grayed out. Cameron,
what version where you using?
Comment 8 Justin Sherrill 2008-04-15 17:02:55 EDT
i think this is on qa?
Comment 9 David Kovalsky 2008-04-16 09:50:28 EDT
Sure it was. I switched purposely to NEEDINFO to get more information from
Cameron who has tested the bug, since I'm getting different testing results. 
Comment 10 Michal Nowak 2008-04-17 06:51:49 EDT
I did not have luck with reproducing this with old version from RHEL-5.0
(rhn-client-tools-0.4.13-1.el5) nor one from 5.1, guess something changed on the
server side but that's not that important.

I do this scenarios with latest revision 0.4.17-8:

1)

login in TUI app via my personal account and pass to RHN, I see screen that I
have no active subscription, which is OK, I hit back, issue QE login, with
unlimited amount of subscriptions and hit next, it logs me into, but I got the
"no active subscription" again.

Justin, is this the reported bug, or is it a new one?

2)

Doing this in reverse order, QE credentials and then personal one gives me
expected results, of no no active subscription.
Comment 11 Justin Sherrill 2008-04-17 12:40:28 EDT
hrm, that seems to be a new bug actually...
Comment 12 Justin Sherrill 2008-04-17 12:54:17 EDT
opened up bz 442930 and proposed for 5.3 as it does not seem to be a blocker.
Comment 13 Michal Nowak 2008-04-18 03:06:32 EDT
Jesus, do you know what version of rhn-client-tools was the affected? When did
you seen it reproducible last time?
Comment 14 Justin Sherrill 2008-04-18 17:42:47 EDT
Michal,

I believe the reason you weren't able to reproduce is because EUS was not
enabled on the server.  With the version of rhn-client-tools released with RHEL
5.1 you see the issue if you were connecting to hosted when it did not have EUS
enabled.

-Justin
Comment 17 errata-xmlrpc 2008-05-21 12:50:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0362.html

Note You need to log in before you can comment on or make changes to this bug.