Bug 253123 - Yum fazed by removal of kernel packages from rawhide repo
Yum fazed by removal of kernel packages from rawhide repo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-16 19:42 EDT by Paul Henshall
Modified: 2014-01-21 17:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 14:58:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Henshall 2007-08-16 19:42:01 EDT
Description of problem:

Yum seems to get confused about the kernel packages being removed from the
repositories. On trying to upgrade the kernel, it complains about kmod-nvidia
needing kernel 2.6.23-0.101.rc2.git5.fc8 - note that this version is installed,
and is not set to be removed. Perhaps the problem is more related to not having
a kernel module for 2.6.23-0.110.rc3.git1.fc8, but this can't be built and
installed until I have downloaded and installed the kernel.

Obviously, this is not difficult to work around. Temporarily removing, then
reinstalling the kernel module after updating works fine, and this isn't a
problem for the release repos, as I guess the old kernels hang around in them.
I just think yum shouldn't be complaining about a dependency which is solved by
installed rpms.

Output follows:

Resolving Dependencies
--> Running transaction check
---> Package kernel.i686 0:2.6.23-0.110.rc3.git1.fc8 set to be updated
---> Package kernel-devel.i686 0:2.6.23-0.110.rc3.git1.fc8 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.23-0.101.rc2.git5.fc8 for package:
kmod-nvidia
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.i686 0:2.6.23-0.110.rc3.git1.fc8 set to be updated
---> Package kernel.i686 0:2.6.23-0.73.rc2.fc8 set to be erased
---> Package kernel-devel.i686 0:2.6.23-0.73.rc2.fc8 set to be erased
---> Package kernel-devel.i686 0:2.6.23-0.110.rc3.git1.fc8 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.23-0.101.rc2.git5.fc8 for package:
kmod-nvidia
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-i686 = 2.6.23-0.101.rc2.git5.fc8 is needed by
package kmod-nvidia
[root@nero ~]# rpm -q kernel
kernel-2.6.23-0.73.rc2.fc8
kernel-2.6.23-0.101.rc2.git5.fc8


Version-Release number of selected component (if applicable):
yum-3.2.2-3.fc8 (also current fc7)

How reproducible:
Install a kernel module for a couple of kernels, wait for kernel updates in
rawhide, try to update kernel.
  
Actual results:

As shown above.

Expected results:

Kernel installed.

Additional info:

Not sure what the generic correct result should be, as it could lead to
interesting edge cases if repos (esp. third party) are unavailable or have
inadvertent errors. Feel free to close as wontfix.
Comment 1 Jeremy Katz 2007-08-20 13:54:28 EDT
Do you have the fedorakmod plugin installed?
Comment 2 Paul Henshall 2007-08-22 18:02:06 EDT
Yes. Here's a full list of the command and output:

[root@nero ~]# yum update kernel kernel-devel
Loading "fedorakmod" plugin
Loading "fastestmirror" plugin
Setting up Update Process
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package kernel.i686 0:2.6.23-0.115.rc3.git1.fc8 set to be updated
---> Package kernel-devel.i686 0:2.6.23-0.115.rc3.git1.fc8 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.23-0.110.rc3.git1.fc8 for package:
kmod-nvidia
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel-devel.i686 0:2.6.23-0.101.rc2.git5.fc8 set to be erased
---> Package kernel-devel.i686 0:2.6.23-0.115.rc3.git1.fc8 set to be updated
---> Package kernel.i686 0:2.6.23-0.115.rc3.git1.fc8 set to be updated
---> Package kernel.i686 0:2.6.23-0.101.rc2.git5.fc8 set to be erased
--> Processing Dependency: kernel-i686 = 2.6.23-0.101.rc2.git5.fc8 for package:
kmod-nvidia
--> Processing Dependency: kernel-i686 = 2.6.23-0.110.rc3.git1.fc8 for package:
kmod-nvidia
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package kernel.i686 0:2.6.23-0.101.rc2.git5.fc8 set to be erased
---> Package kmod-nvidia.i686 0:100.14.11-1.2.6.23_0.101.rc2.git5.fc8 set to be
erased
--> Processing Dependency: kernel-i686 = 2.6.23-0.110.rc3.git1.fc8 for package:
kmod-nvidia
--> Finished Dependency Resolution
Error: Unresolveable requirement kernel-i686 = 2.6.23-0.110.rc3.git1.fc8 for
kmod-nvidia

Obviously yum is trying to check if 2.6.23-0.110.rc3.git1.fc8 conflicts with
anything, but since it has been removed from the repo, it can't check, even
though it is installed and not set to be removed.

As this situation wouldn't occur with the release distro, and I can't really
come up with a situation outside of rawhide that it would be a problem, it's
probably not worth worrying about.
Comment 3 Jeremy Katz 2007-09-13 14:58:54 EDT
yum 3.2.5 should be better here

Note You need to log in before you can comment on or make changes to this bug.