Bug 253129 - Fedora 7 install hangs, flogging swap
Fedora 7 install hangs, flogging swap
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-16 21:21 EDT by Joe Christy
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 22:10:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A representative install log, captured by adding syslog= to the boot commandline (8.67 KB, text/plain)
2007-08-16 21:21 EDT, Joe Christy
no flags Details

  None (edit)
Description Joe Christy 2007-08-16 21:21:15 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
frustratingly

Steps to Reproduce:
1.Try to perform  fresh install of F7 on Thinkpad T42p w/ 1GB RAM
2.Try to install more than a bare minimum of packages
3.
  
Actual results:
After about 1100 packages, anaconda starts to flog swap and eventually hangs

Expected results:
Install succeeds as it did with FC6 on the same machine w/ same partition
scheme, and FC5 before that, and FC4 before that ...

Additional info:
memtest86+ finds no problem with RAM and system sailed through a forced fsck
under FC6, so I believe that the disc is OK. sha1 sum of i386 DVD iso image I
began with checked out, and I have been able to perform network installs to
other machines from the exploded Fedora on my build server, so I believe that
the installation medium is OK.

I have 1GB RAM and a 80GB disc with 4 primary physical partitions: 100MB /boot,
two 2GB swaps, and the rest is one LVM physical volume. There are 5 logical
volumes under LVM: 15GB /, 2.5 GB /var, 2.5GB /tmp, 15GB /home, and 30GB /usr/local.

At first I tried to simply reformat my /boot, swaps, /, /var, and /tmp, while
preserving /home and /usr/local. I chose to do a network install from NFS from
my build server as I habitually do. As the install progressed, system grew
slower and disc activity grew, until install finally hung, I could painfully
switch to other ttys, if I waited about 5 minutes, but sh# prompt was defunct
and the only problem on the other ttys was a warning from anaconda about
progress.py from much earlier in the install. I ultimately had to do a hard
power-down.

I tried again with the same partition setup but installing from a DVD that I
burned from the sha1-checked iso image, which also passed the medium install
check. Same failure.

In fact same thing happens with every install method I tried with any usable set
of packages selected, even after I wiped the disk and started from scratch. A
few times, but not every time, one of the ttys would show a stack trace which I
didn't want to transcribe by hand, esp. since the top had scrolled off the screen.

Checking bugzilla, it appears that others have encountered some problems that
could be the same, but are still open, presumably since they don't have
sufficient information in them. I did find a mention of an updated image in bz
241991 (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=241991), but using
it didn't help.

I was able to do an absolutely minimal install by unchecking everything and
using the default partition scheme (which doesn't really meet my needs). That is
how I installed memcheck86+, but I dread having to add all my accustomed sw by
hand. Manually adding all my accustomed sw seems an overly daunting task.
Comment 1 Joe Christy 2007-08-16 21:21:15 EDT
Created attachment 161710 [details]
A representative install log, captured by adding syslog= to the boot commandline
Comment 2 Bug Zapper 2008-05-14 10:00:43 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Andy Lindeberg 2008-06-03 16:56:45 EDT
Have you encountered the same problem when upgrading to Fedora 9?
Comment 4 Bug Zapper 2008-06-16 22:10:42 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.