Bug 25315 - xforms breaks compilation of LyX
Summary: xforms breaks compilation of LyX
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: xforms   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-30 18:08 UTC by adam.huffman
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-30 18:08:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description adam.huffman 2001-01-30 18:08:45 UTC
xforms as supplied with Powertools breaks compilation of LyX.

It seems to include something it shouldn't, leading to errors such as:

In file included from formula.C:30:
../../src/minibuffer.h:17: using directive 'Object' introduced
ambiguous type '_ObjectRec *'
make[3]: *** [formula.lo] Error 1

I managed to get the compilation working by using an older RPM of xforms,
namely
0.88-9

Comment 1 Ngo Than 2001-02-05 15:21:08 UTC
It's fixed in xforms-0.88-16.
Note: we don't have xforms in 7.1, because it's not GPL. You could download the
new packages
from www.linux-easy.com.


Note You need to log in before you can comment on or make changes to this bug.