Bug 253177 - .ods opened as ZIP file
.ods opened as ZIP file
Status: CLOSED DUPLICATE of bug 225339
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openoffice.org (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 06:17 EDT by Boris Folgmann
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 09:19:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Folgmann 2007-08-17 06:17:38 EDT
Description of problem:
openoffice.org2 works fine, but files like .ods are displayed with a ZIP icon in
Nautilus and opened as ZIP files instead by oowriter2.

Version-Release number of selected component (if applicable):
openoffice.org2-draw-2.0.4-5.7.0.1.0
openoffice.org2-graphicfilter-2.0.4-5.7.0.1.0
openoffice.org2-impress-2.0.4-5.7.0.1.0
openoffice.org2-writer-2.0.4-5.7.0.1.0
openoffice.org2-javafilter-2.0.4-5.7.0.1.0
openoffice.org2-math-2.0.4-5.7.0.1.0
openoffice.org2-xsltfilter-2.0.4-5.7.0.1.0
openoffice.org2-emailmerge-2.0.4-5.7.0.1.0
openoffice.org2-langpack-de-2.0.4-5.7.0.1.0
openoffice.org2-core-2.0.4-5.7.0.1.0
openoffice.org2-base-2.0.4-5.7.0.1.0
openoffice.org2-calc-2.0.4-5.7.0.1.0
openoffice.org2-pyuno-2.0.4-5.7.0.1.0

Additional info:
Perhaps the magicfile for file is the problem. file reports .ods files as
"Zip archive data, at least v2.0 to extract"
Whereas .sdw files are reported as "Microsoft Office Document"
But I don't know if Nautilus uses the same data base.
Comment 1 Caolan McNamara 2007-08-17 09:19:25 EDT

*** This bug has been marked as a duplicate of 225339 ***

Note You need to log in before you can comment on or make changes to this bug.