Bug 25319 - Install hangs at "Loading cpqarray ... "
Install hangs at "Loading cpqarray ... "
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-30 13:28 EST by mitchell mcgee
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-02 16:10:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description mitchell mcgee 2001-01-30 13:28:10 EST
As directed by Steve and Red Hat installation support I submitting the 
following information for a resolution.

We wish to convert our web server to a RAID configuration.  To accomplish 
this, I am attempting to install RH 7 on a Compaq Proliant 1600 w/RAID 5 
using the Compaq Smart Array 221 array controller and 3 Ultra Wide SCSI 
9.1 GB drives. In my efforts to find the right configuration to allow RH 7 
to install, the controller's operating system variable has been set as MS 
DOS/Windows, Linux, and UnixWare 2, and in each case, whether attempting 
to launch the install from the CD or supplied boot disk it hangs when the 
GUI displays "Loading cpqarray ...".  The servers's system and options 
firmware has been update using the rompaqs supplied with the Smart Array 
221 controller.

In addition to the default install option, I have tried installing under 
expert mode. While the list of SCSI devices does not specifically identify 
the Smart Array 221 controller, I have assumed the "Compaq Smart/2 RAID 
Controller" is the correct option. I don't know of any module parameters 
that need to be specified. The results are the same, the install hangs at 
the window with the message "Loading cpqarray ... ". 

I have also been corresponding with Charles White of Compaq at 
Charles.White@COMPAQ.com regarding the correct controller configuration. 
He has instructed me to configure the controller OS as UnixWare 2.0x. I 
also have disconnected the only other SCSI device on the machine, a 4/8GB 
DAT DRV, as he had a problem reported loading RH 6.2 with multiple SCSI 
devises attached. 

We have been able to successfully load RH 7 on a Proliant ML370 using the 
same Smart Array 221 controller, although the array controller has an 
earlier firmware version 4.14 vs. 4.44.  The controller was also 
configured with the MS DOS/Windows OS option.  Charles has been made aware 
of this, but I have had no report back from him following that note.  
Currently, the OS setting on the server on which I'm attempting to install 
has been set back to UnixWare 2.0x
Comment 1 Michael Fulbright 2001-01-31 13:28:27 EST
Assigning to a developer.
Comment 2 mitchell mcgee 2001-01-31 16:20:46 EST
I have attempted loading RH 6.2 on the same server with similar results, 
however, 6.2 will successfully load the ncr538xx driver prior to attempting to 
load the cpqarray driver.  So, this appears to be cpqarray specifc.  RH 7 
either does not need the ncr538xx driver, or does not attempt to load it prior 
to loading cpqarray.
Comment 3 Matt Wilson 2001-01-31 23:47:55 EST
can you swtich to VC 4 and see any kernel messages that may help find the cause
of the lockup?
Comment 4 mitchell mcgee 2001-02-01 11:42:55 EST
The VC function does not work once the process hangs, but I was able to 
retrieve the following messages immediately after the root mount was complete.

RH7 VC3 -
* finished bus probing
* found suggestion of cpqarray
* found cpqarray device
* found suggestion of ncr53c8xx
* found ncr53c8xx device
* found devices justProbe is 0
* going to insmod cpqarray.o (path is NULL)

RH7 VC4 did not display any messages after -
<4> VFS: Mounted root (ext2 filesystem)

RH6.2 VC3 -
* finished bus probing
* found suggestion of cpqarray
* found cpqarray device
* found suggestion fof tlan
* found tlan device
* found suggestion of ncr53c8xx
* found ncr53c8xx device
* found suggestion of Card: Cirrus Logic GD503x
* found devices justProbe is 0
* going to insmod tlan.o (path is NULL)
* going to insmod cpqarray.o (path is NULL)

RH6.2 VC4 -
<4> VFS: Mounted root (ext2 filesystem)
<6> ncr53c8xx: at PCI bus 0, device 8, function 0
<6> ncr53c8xx: 53c875 detected
<6> ncr53c8xx: at PCI bus 1, device 9, function 0
<6> ncr53c8xx: 53c875 detected
<6> ncr53c8xx-0: rev=0x04, base=0xb7ffcf00, io-port 0x6000, irq=5
<4> ncr53c8xx-0: NCR clockk is 40401KHz, 40218KHz
<6> ncr53c8xx-0: ID7 ,Fast-20, Parity Check
<6> ncr53c8xx-0: on-chip RAM at 0xb7fff000
<6> ncr53c8xx-0: restart (scsi reset)
<4> ncr53c8xx-0: Dowloading SCSI SCRIPTS
<6> ncr53c8xx-1: rev=0x04, base=0xc6efcf00, io-port=0x7000, irq=9
<6> ncr53c8xx-1: ID 7, Fast-20, Parity Check
<6> ncr53c8xx-1: on-chip RAM at 0xc6bef000
<6> ncr53c8xx-1: restart (scsi reset)
<4> ncr53c8xx-1: Downloading SCSI SCRIPTS
<4> scsi0: ncr53c8xx-version 3.2a-2
<4> scsi1: ncr53c8xx-version 3.2a-2
<4> : 2 hosts
<7> ISO 9660 Extensions: Microsoft Joliet Level 1
<7> ISO 9660 Extensions: RRIP-1991 A
<4> TLAN driver.v1.0,(C) 1997-8 Caldera, Inc.
<4> TLAN: eth0 irq=10 io=7400, Compaq Netelligent Integrated 10/1000 TXUTP, 
Rev. 16
Comment 5 Matt Wilson 2001-02-02 10:34:58 EST
If it completely hangs it's going to be a driver problem or a card configuration
problem.
Comment 6 mitchell mcgee 2001-02-02 15:58:49 EST
As noted earlier, I've been working with Charles White at Compaq to help ensure 
the controller is configured properly.  The cpqarray driver is included with 
the Red Hat 7 installation CD, is it not?
Comment 7 Matt Wilson 2001-02-02 16:10:28 EST
So the install went ok with the smart array on the ml 370 with firmware 4.14.
The only other difference is the drives and the server box?  Is there any way to
downgrade the firmware on the card in question to 4.14 to match?
Comment 8 mitchell mcgee 2001-02-08 16:56:41 EST
This has been resolved.

After getting the most recent System Rompaqs loaded and disconnecting all other 
SCSI devices and removing any other add-on cards, the install went just fine.  
I wish I could tell you which of the actions was the key, but they were all in 
effect at the time the install successfully ran.  I suspect the Rompaq versions 
were not compatible with the 4.44 firmware version on the Smart Array 221 
controller, but I can't be positive.

Thanks for you time and assistance.

Note You need to log in before you can comment on or make changes to this bug.