Bug 253237 - vim-selinux.patch: mch_copy_sec declared implicitly only
Summary: vim-selinux.patch: mch_copy_sec declared implicitly only
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: bzcl34nup
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-17 14:59 UTC by Sami Farin
Modified: 2008-06-03 13:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 13:34:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sami Farin 2007-08-17 14:59:08 UTC
Description of problem:
This means that function parameters passed are ints, not char*.
This leads to problems when sizeof(char*) != sizeof(int).
Maybe add correct declaration into vim.h?  That's what I did.

Also, return type of mch_copy_sec is int, because you were too lazy
to use keyword "void"...

Version-Release number of selected component (if applicable):


How reproducible:
N/A

Steps to Reproduce:
1. N/A
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Bug Zapper 2008-04-04 13:37:19 UTC
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 2 Karsten Hopp 2008-06-03 13:34:55 UTC
The latest vim has a declaration of mch_copy_sec in src/proto/os_unix.pro which
gets included by vim.h via proto.h. A rebuild shows no warnings about implicit
declarations.


Note You need to log in before you can comment on or make changes to this bug.