Bug 253246 - Autofs negative cache regression
Autofs negative cache regression
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.8
All Linux
high Severity high
: rc
: ---
Assigned To: Ian Kent
Brock Organ
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 11:33 EDT by Guil Barros
Modified: 2009-07-20 05:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-20 12:11:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 RHEL Product and Program Management 2007-08-17 11:45:27 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 RHEL Product and Program Management 2007-08-17 11:46:07 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 3 RHEL Product and Program Management 2007-08-17 12:15:31 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Ian Kent 2007-08-17 14:24:35 EDT
(In reply to comment #5)
> Hmm. Not customer reported and only medium/low. The problem only happens if the
> config is wrong, right? (or what is a bad path?)

Not quite.

This is a customer problem, I'll leave it to Guil to confirm.

The actual problem is that a patch to remove this function was
added to our RHEL3 version 2.4 kernel at about the same time it
was removed from from the 2.6 kernel. The removal of the
functionality from the 2.6 kernel had no effect since changes
to the VFS prevented this functionality from working "at all".
Unfortunately, as we know now, this isn't the case with the
2.4 kernel and the problem above was a direct result of the
removal.

So I recommend we revert the change.

The bad paths referred to above are, I believe, embedded in
system scripts and applications as search paths which cause
automount requests which cause lengthy delays waiting for
non-existent requests to fail and cannot be feasibly changed
or removed.

Ian
Comment 7 Guil Barros 2007-08-20 11:09:47 EDT
I must have forgotten to set some flags. This is a current customer problem that
was not existent until we removed the negative cache setting.

Ian is right, the bad paths are in current apps that can't be easily changed.

Note You need to log in before you can comment on or make changes to this bug.