Bug 253325 - ppc build of ruby-libs has an extra dependency on tcl/tk
ppc build of ruby-libs has an extra dependency on tcl/tk
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
6
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 16:58 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.8.5.114-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 23:29:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2007-08-17 16:58:43 EDT
Description of problem:
The ppc build of ruby-libs has a dependency on tcl/tk, while other builds (i386,
x86_64, ppc64) don't. The dependencies should be consistent across all arches,
shouldn't they?

$ rpmdiff ruby-libs-1.8.5.52-1.fc6.i386.rpm ruby-libs-1.8.5.52-1.fc6.ppc.rpm |
egrep 'tcl|tk|X11'
added      REQUIRES libX11.so.6  
added      REQUIRES libtcl8.4.so  
added      REQUIRES libtk8.4.so  
added      PROVIDES tcltklib.so  
added      PROVIDES tkutil.so  
added      /usr/lib/ruby/1.8/powerpc-linux/tcltklib.so
added      /usr/lib/ruby/1.8/powerpc-linux/tkutil.so

This has caused my recent obexftp build to fail on ppc:
http://buildsys.fedoraproject.org/logs/fedora-6-extras/35720-obexftp-0.22-0.2.rc6.fc6/ppc/root.log
while it built properly on i386:
http://buildsys.fedoraproject.org/logs/fedora-6-extras/35720-obexftp-0.22-0.2.rc6.fc6/i386/root.log

Version-Release number of selected component (if applicable):
ruby-libs-1.8.5.52-1.fc6

Additional Information:
Thanks to jima for pinning it down. :)
Comment 1 Akira TAGOH 2007-08-20 02:32:27 EDT
Hmm, doh. probably the spec file has to be rewritten to not generate the
manifest automatically. that should helps a lot in this case.. sorry for
bothering you.
Comment 2 Akira TAGOH 2007-10-15 09:23:41 EDT
Fixed in 1.8.5.113-2.
Comment 3 Fedora Update System 2007-10-15 17:32:07 EDT
ruby-1.8.6.110-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ruby'
Comment 4 Dominik 'Rathann' Mierzejewski 2007-10-24 18:25:36 EDT
(In reply to comment #2)
> Fixed in 1.8.5.113-2.

I'm afraid not...

$ rpmdiff ruby-libs-1.8.5.113-2.fc6.i386.rpm ruby-libs-1.8.5.113-2.fc6.ppc.rpm
added      REQUIRES libX11.so.6  
added      REQUIRES libtcl8.4.so  
added      REQUIRES libtk8.4.so  
added      PROVIDES tcltklib.so  
added      PROVIDES tkutil.so  
...
Comment 5 Akira TAGOH 2007-10-29 06:59:41 EDT
Doh, thanks for catching up. surely 1.8.5.113-3 should works.
Comment 6 Dominik 'Rathann' Mierzejewski 2007-10-29 15:04:37 EDT
I can't find it on the mirrors yet (in updates-testing, that is).
Comment 7 Dominik 'Rathann' Mierzejewski 2007-11-07 13:39:00 EST
Looks like it's really fixed this time, thanks.

Note You need to log in before you can comment on or make changes to this bug.