Bug 253359 - glibc detected *** stardict: malloc(): memory corruption
glibc detected *** stardict: malloc(): memory corruption
Status: CLOSED DUPLICATE of bug 252712
Product: Fedora
Classification: Fedora
Component: stardict (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Hu Zheng
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-18 03:19 EDT by Ronald Warsow
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-19 22:02:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Warsow 2007-08-18 03:19:46 EDT
Description of problem:


Version-Release number of selected component (if applicable):
stardict-3.0.0-1.fc7
glibc-2.6-4

How reproducible:


Steps to Reproduce:
1. start stardict from comand line
2.
3.
  
Actual results:

splash screen comes up 
and

*** glibc detected *** stardict: malloc(): memory corruption: 0x0000000000926ee0 ***
======= Backtrace: =========
/lib64/libc.so.6[0x36c0070bcc]
/lib64/libc.so.6(__libc_malloc+0x7d)[0x36c00724ed]
/usr/lib64/libespeak.so.1[0x2aaab0aa9dd9]
/usr/lib64/libespeak.so.1[0x2aaab0ab5c3e]
/usr/lib64/libespeak.so.1(espeak_Initialize+0x52)[0x2aaab0aa9102]
/usr/lib64/stardict/plugins/stardict_espeak.so(stardict_tts_plugin_init+0x18)[0x2aaab0892708]
stardict(_ZN15StarDictPlugins11load_pluginEPKc+0x4ee)[0x49d2be]
stardict(_Z15__for_each_fileI12PluginLoaderEvRKSsS2_RKSt4listISsSaISsEES7_T_+0x1e7)[0x49f767]
stardict(_Z13for_each_fileI12PluginLoaderEvRKSt4listISsSaISsEERKSsS5_S5_T_+0xd7)[0x49f9c7]
stardict(_ZN15StarDictPlugins4loadEPKcRKSt4listISsSaISsEES6_+0xad)[0x49d5ed]
stardict(_ZN15StarDictPluginsC1EPKcRKSt4listISsSaISsEES6_+0xa4)[0x49d7e4]
stardict(_ZN7AppCore6CreateEPc+0x1f2)[0x433e92]
stardict(_ZN7AppCore4InitEPc+0x418)[0x4356e8]
stardict(main+0x27e)[0x43606e]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x36c001dab4]
stardict[0x42b0d9]
======= Memory map: ========
00400000-004c1000 r-xp 00000000 08:01 689975                            
/usr/bin/stardict
006c1000-006e3000 rw-p 000c1000 08:01 689975                            
/usr/bin/stardict
006e3000-0092f000 rw-p 006e3000 00:00 0                                  [heap]
30f7600000-30f7606000 r-xp 00000000 08:01 689170                        
/usr/lib64/libportaudio.so
30f7606000-30f7805000 ---p 00006000 08:01 689170                        
/usr/lib64/libportaudio.so
30f7805000-30f7806000 rw-p 00005000 08:01 689170                        
/usr/lib64/libportaudio.so
314f000000-314f09d000 r-xp 00000000 08:01 1858659                       
/lib64/libglib-2.0.so.0.1200.13
314f09d000-314f29c000 ---p 0009d000 08:01 1858659                       
/lib64/libglib-2.0.so.0.1200.13
314f29c000-314f29e000 rw-p 0009c000 08:01 1858659                       
/lib64/libglib-2.0.so.0.1200.13
314f400000-314f43e000 r-xp 00000000 08:01 1858660                       
/lib64/libgobject-2.0.so.0.1200.13
314f43e000-314f63e000 ---p 0003e000 08:01 1858660                       
/lib64/libgobject-2.0.so.0.1200.13
314f63e000-314f640000 rw-p 0003e000 08:01 1858660                       
/lib64/libgobject-2.0.so.0.1200.13
314f800000-314f803000 r-xp 00000000 08:01 1858661                       
/lib64/libgmodule-2.0.so.0.1200.13
314f803000-314fa02000 ---p 00003000 08:01 1858661                       
/lib64/libgmodule-2.0.so.0.1200.13
314fa02000-314fa03000 rw-p 00002000 08:01 1858661                       
/lib64/libgmodule-2.0.so.0.1200.13
314fc00000-314fc17000 r-xp 00000000 08:01 689974                        
/usr/lib64/libgdk_pixbuf-2.0.so.0.1000.14
314fc17000-314fe16000 ---p 00017000 08:01 689974                        
/usr/lib64/libgdk_pixbuf-2.0.so.0.1000.14
314fe16000-314fe17000 rw-p 00016000 08:01 689974                        
/usr/lib64/libgdk_pixbuf-2.0.so.0.1000.14
3150000000-315001d000 r-xp 00000000 08:01 702935                        
/usr/lib64/libatk-1.0.so.0.1809.1
315001d000-315021c000 ---p 0001d000 08:01 702935                        
/usr/lib64/libatk-1.0.so.0.1809.1
315021c000-315021f000 rw-p 0001c000 08:01 702935                        
/usr/lib64/libatk-1.0.so.0.1809.1
3150400000-315048f000 r-xp 00000000 08:01 702237                        
/usr/lib64/libgdk-x11-2.0.so.0.1000.14
315048f000-315068f000 ---p 0008f000 08:01 702237                        
/usr/lib64/libgdk-x11-2.0.so.0.1000.14
315068f000-3150694000 rw-p 0008f000 08:01 702237                        
/usr/lib64/libgdk-x11-2.0.so.0.1000.14
3150800000-3150841000 r-xp 00000000 08:01 697905                        
/usr/lib64/libpango-1.0.so.0.1600.4
3150841000-3150a40000 ---p 00041000 08:01 697905                        
/usr/lib64/libpango-1.0.so.0.1600.4
3150a40000-3150a43000 rw-p 00040000 08:01 697905                        
/usr/lib64/libpango-1.0.so.0.1600.4
3150c00000-3150c08000 r-xp 00000000 08:01 699111                        
/usr/lib64/libpangocairo-1.0.so.0.1600.4
3150c08000-3


Expected results:


Additional info:
Comment 1 Hu Zheng 2007-08-19 22:02:49 EDT

*** This bug has been marked as a duplicate of 252712 ***

Note You need to log in before you can comment on or make changes to this bug.