Bug 253385 - Saved session not restored properly
Saved session not restored properly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-18 13:30 EDT by Tom London
Modified: 2008-04-04 09:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 09:49:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'ps agx' after reboot/logging in: no compiz, no gtk-window-decorator (7.96 KB, text/plain)
2007-08-18 15:35 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2007-08-18 13:30:28 EDT
Description of problem:
Saving/restoring sessions state (e.g., open windows, applets) appears not to
work properly: windows/apps are most often placed, but no compiz and no window
decorations.

Here is what I did: I had a preferred/working session with metacity. I
'converted' to compiz via 'desktop-effects' and saved session using
gnome-session-properties.  Have nice session. Log off/log back in. No compiz, no
gtk-window-decorator.  'ps agx | grep compiz' shows no compiz running.

~/.gnome2/session:

[tbl@localhost .gnome2]$ cat session

[Default]
0,id=117f000001000118745421400000303340005
0,RestartStyleHint=2
0,Priority=60
0,Program=pam-panel-icon
0,CurrentDirectory=/home/tbl
0,CloneCommand=/usr/bin/pam-panel-icon 
0,RestartCommand=/usr/bin/pam-panel-icon --sm-client-id
117f000001000118745421400000303340005 
0,Environment=
1,id=117f000001000118745428400000303340008
1,RestartStyleHint=0
1,Program=pidgin
1,CurrentDirectory=/home/tbl
1,DiscardCommand=/bin/true 
1,CloneCommand=pidgin 
1,RestartCommand=pidgin --session 117f000001000118745428400000303340008 
2,id=117f000001000118745421400000303340001
2,RestartStyleHint=1
2,Priority=40
2,Program=gnome-volume-manager
2,CurrentDirectory=/home/tbl
2,CloneCommand=gnome-volume-manager --sm-config-prefix
/gnome-volume-manager-Hsxs8w/ 
2,RestartCommand=gnome-volume-manager --sm-config-prefix
/gnome-volume-manager-Hsxs8w/ --sm-client-id
117f000001000118745421400000303340001 --screen 0 
3,id=117f000001000118745421400000303340004
3,Program=gnome-power-manager
3,CurrentDirectory=/home/tbl
3,CloneCommand=gnome-power-manager --sm-config-prefix /gnome-power-manager-Wt0Tfx/ 
3,RestartCommand=gnome-power-manager --sm-config-prefix
/gnome-power-manager-Wt0Tfx/ --sm-client-id
117f000001000118745421400000303340004 --screen 0 
4,id=117f000001000118745421400000303340000
4,RestartStyleHint=2
4,Priority=40
4,Program=nautilus
4,CurrentDirectory=/home/tbl
4,CloneCommand=nautilus --sm-config-prefix /nautilus-bIzP2w/ --load-session
/home/tbl/.nautilus/saved-session-JJ9EXT 
4,RestartCommand=nautilus --sm-config-prefix /nautilus-bIzP2w/ --sm-client-id
117f000001000118745421400000303340000 --screen 0 --load-session
/home/tbl/.nautilus/saved-session-FXL1WT 
5,id=117f000001000118745499700000318760003
5,RestartStyleHint=2
5,CloneCommand=compiz --replace --ignore-desktop-hints glib gconf 
5,RestartCommand=compiz --replace --ignore-desktop-hints glib gconf 
6,id=117f000001000118745424000000303340006
6,Program=gnome-terminal
6,CurrentDirectory=/home/tbl
6,CloneCommand=gnome-terminal --sm-config-prefix /gnome-terminal-YB3Tcx/
--window-with-profile-internal-id=Default --show-menubar
--role=gnome-terminal-30581-883526785-1187454240 --active --geometry 80x24+3+48
--title tbl@localhost:~ --working-directory /home/tbl --zoom 1
--window-with-profile-internal-id=Default --show-menubar
--role=gnome-terminal-30581--223345347-1187454246 --active --geometry
80x24+4+510 --title tbl@localhost:~ --working-directory /home/tbl --zoom 1 
6,RestartCommand=gnome-terminal --sm-config-prefix /gnome-terminal-YB3Tcx/
--sm-client-id 117f000001000118745424000000303340006 --screen 0
--window-with-profile-internal-id=Default --show-menubar
--role=gnome-terminal-30581-883526785-1187454240 --active --geometry 80x24+3+48
--title tbl@localhost:~ --working-directory /home/tbl --zoom 1
--window-with-profile-internal-id=Default --show-menubar
--role=gnome-terminal-30581--223345347-1187454246 --active --geometry
80x24+4+510 --title tbl@localhost:~ --working-directory /home/tbl --zoom 1 
7,id=117f000001000118745429300000303340009
7,Program=rhythmbox
7,CurrentDirectory=/home/tbl
7,CloneCommand=rhythmbox --sm-config-prefix /rhythmbox-Q2HAbv/ 
7,RestartCommand=rhythmbox --sm-config-prefix /rhythmbox-Q2HAbv/ --sm-client-id
117f000001000118745429300000303340009 --screen 0 
8,id=117f000001000118745421400000303340002
8,RestartStyleHint=2
8,Priority=40
8,Program=gnome-panel
8,CurrentDirectory=/home/tbl
8,CloneCommand=gnome-panel --sm-config-prefix /gnome-panel-MnwWUv/ 
8,RestartCommand=gnome-panel --sm-config-prefix /gnome-panel-MnwWUv/
--sm-client-id 117f000001000118745421400000303340002 --screen 0 
9,RestartCommand=gnome-volume-manager --sm-disable 
10,RestartCommand=nm-applet --sm-disable 
11,RestartCommand=/usr/bin/system-config-printer-applet 
12,RestartCommand=/usr/bin/sealert 
num_clients=13
[tbl@localhost .gnome2]$ 



Version-Release number of selected component (if applicable):
compiz-gnome-0.5.2-6.0ec3ec.fc8
compiz-0.5.2-6.0ec3ec.fc8


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2007-08-18 15:35:24 EDT
Created attachment 161806 [details]
'ps agx' after reboot/logging in: no compiz, no gtk-window-decorator

After rebooting and logging in again, I get windows and apps, but no compiz and
no gtk-window-decorator.

Attached is output from 'ps agx'.

Does compiz produce a log somewhere?
Comment 2 Tom London 2007-08-18 15:48:49 EDT
By any chance, does compiz need to be started with LIBGL_ALWAYS_INDIRECT=1, or
some such?
Comment 3 Tom London 2007-08-18 16:03:54 EDT
(In reply to comment #2)
> By any chance, does compiz need to be started with LIBGL_ALWAYS_INDIRECT=1, or
> some such?

I think this is part of it.

I renamed /usr/bin/compiz as /usr/bin/compiz.bin, and created a new
/usr/bin/compiz as:

[tbl@localhost ~]$ cat /usr/bin/compiz
#!/bin/sh

echo LIBGL_ALWAYS_INDIRECT=1 compiz.bin "$@" >>/tmp/compiz.log
LIBGL_ALWAYS_INDIRECT=1 compiz.bin "$@"
[tbl@localhost ~]$ 


[Ignore the 'echo' line.....just checking to see that it got called.]

Now when I log in, compiz is running.

Of course, gtk-window-decorator is not. Suppose I could add this as an 'extra
startup program' in gnome-session-properties.

Is there a better way?
Comment 4 Tom London 2007-08-19 12:17:32 EDT
Uhhh.... Looks like the 'right answer' is gnome-compiz-manager.....
Comment 5 Tom London 2007-08-30 14:21:56 EDT
compiz seems to need "LIBGL_ALWAYS_INDIRECT=1", period.

I've added this to my .bash_profile (and exported it).

Otherwise, compiz does not reliably startup when session starts.

Am I doing something wrong?  Is my 'setup' screwy?
Comment 6 Bug Zapper 2008-04-04 09:37:40 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 7 Tom London 2008-04-04 09:49:06 EDT
Either setting "LIBGL_ALWAYS_INDIRECT=1" or "--indirect-rendering" for compiz on
intel 945 graphics hardware seems necessary.

I'm closing this, and will reopen a new bug about window placement of sessions
with compiz, and another BZ about needing a "quirk" for intel hardware.

Note You need to log in before you can comment on or make changes to this bug.