Bug 253423 - kernel does not detect nvidia graphic card
Summary: kernel does not detect nvidia graphic card
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-19 07:47 UTC by pauwel coppieters
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 22:50:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description pauwel coppieters 2007-08-19 07:47:53 UTC
Description of problem:
kernel.i686 2.6.22.2-42.fc6 does not detect nvidia graphic card

Version-Release number of selected component (if applicable):
kernel.i686 2.6.22.2-42.fc6

How reproducible:
always

Steps to Reproduce:
1. boot
2. last message you see is : starting to uncompress kernel
  after a while, you get an normal console login screen (because X failed to
start, because there is no graphic card detected). Reboot with the older kernel
2.6.20-1.2962 "cures" the problem (so the hardware is ok).

Some differences :

[root@localhost log]# diff Xorg.0.log Xorg.0.log.old |more
6c6
< Current Operating System: Linux localhost.localdomain 2.6.20-1.2962.fc6 #1 SMP
Tue Jun 19 19:27:14 EDT 2007 i686
---
> Current Operating System: Linux localhost.localdomain 2.6.22.2-42.fc6 #1 SMP
Wed Aug 15 12:34:26 EDT 2007 i686
15c15
< (==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug 19 09:15:14 2007
---
> (==) Log file: "/var/log/Xorg.0.log", Time: Sat Aug 18 22:39:09 2007
58d57
< (II) PCI: 01:00:0: chip 10de,0201 card 1462,8838 rev a3 class 03,00,00 hdr 00
92d90
< (--) PCI:*(1:0:0) nVidia Corporation NV20 [GeForce3 Ti 200] rev 163, Mem @
0xe0000000/24, 0xd8000000/26, 0xdc000000/19
109,119c107,114
<       [4] -1  0       0xdc000000 - 0xdc07ffff (0x80000) MX[B](B)
<       [5] -1  0       0xd8000000 - 0xdbffffff (0x4000000) MX[B](B)
<       [6] -1  0       0xe0000000 - 0xe0ffffff (0x1000000) MX[B](B)
<       [7] -1  0       0x0000cc00 - 0x0000ccff (0x100) IX[B]
<       [8] -1  0       0x0000c800 - 0x0000c8ff (0x100) IX[B]
<       [9] -1  0       0x0000c400 - 0x0000c4ff (0x100) IX[B]
<       [10] -1 0       0x0000c000 - 0x0000c07f (0x80) IX[B]
<       [11] -1 0       0x0000d800 - 0x0000d81f (0x20) IX[B]
<       [12] -1 0       0x00005000 - 0x0000500f (0x10) IX[B]
<       [13] -1 0       0x0000d000 - 0x0000d01f (0x20) IX[B]
<       [14] -1 0       0x0000f000 - 0x0000f00f (0x10) IX[B]
---
>       [4] -1  0       0x0000cc00 - 0x0000ccff (0x100) IX[B]
>       [5] -1  0       0x0000c800 - 0x0000c8ff (0x100) IX[B]
>       [6] -1  0       0x0000c400 - 0x0000c4ff (0x100) IX[B]
>       [7] -1  0       0x0000c000 - 0x0000c07f (0x80) IX[B]
>       [8] -1  0       0x0000d800 - 0x0000d81f (0x20) IX[B]
>       [9] -1  0       0x00005000 - 0x0000500f (0x10) IX[B]
>       [10] -1 0       0x0000d000 - 0x0000d01f (0x20) IX[B]
>       [11] -1 0       0x0000f000 - 0x0000f00f (0x10) IX[B]
125,135c120,127






3.
  
Actual results:


Expected results:


Additional info:

Comment 1 D. Angelis 2007-08-21 21:37:25 UTC
What driver are using ? Look at Section Device in /etc/X11/xorg.conf 
If Driver is "nvidia" that means you need NVIDIA's proprietary driver to be
installed/reinstalled for the new kernel.
An other thing that needs attention is whether did you have updated any
xorg-*.rpm since you last install/reinstall the NVIDIA's driver since some of
those change either /etc/X11/xorg.conf or /usr/lib/libGL.so.1 or
/usr/lib/xorg/modules/extensions/libglx.so links.( even then a reinstallation of
the NVIDIA's driver would fix the problem).


Comment 2 pauwel coppieters 2007-08-22 22:04:08 UTC
I checked xorg.conf, and the driver I'm using is nv.
Anyway, it's not an X11 problem. The message "starting to uncompress kernel"
happens very early in the boot sequence , and from that point on, there is no
more display at all. The system works though, and typing blind, I can reboot the
system.

Comment 3 pauwel coppieters 2007-08-22 22:50:34 UTC
Today,I tried booting again with 2.6.22 (i switched back to 2.6.20 for the time
being) and the problem is vanished. I can not produce it any more in any way. 
Therefor I propose to close this case (I did set resolution to 'NOTABUG')

Sorry for the unnecessary troubles.


Note You need to log in before you can comment on or make changes to this bug.