Bug 253470 - anonymous window with the icon of a gear and progress bar flashes on the display
anonymous window with the icon of a gear and progress bar flashes on the display
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-19 23:33 EDT by xunilarodef
Modified: 2013-03-05 22:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 19:54:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xunilarodef 2007-08-19 23:33:22 EDT
Description of problem: 
  Visual distraction and wasteful consumption of computing resources
by a little window popping up, and soon going away all by itself
(fortunately, since it contained no controls to close it).  Repeatedly.

Version-Release number of selected component (if applicable):
at-spi-1.19.5-1.fc8 on the f8t1 LiveCD
at-spi-1.19.5-2.fc8 on f8 rawhide

How reproducible:
  All of the time.

Steps to Reproduce:
1. Boot an installed Fedora 8 rawhide system, and observe, or
2. Boot Fedora-8-Test-1-Live-i686 LiveCD, and observe.

Actual results:
An anonymous window containing only the icon of a gear (or waterwheel?) 
and a short completed progress bar flashes on the display for a few 
seconds, with an irregular interval of approximately every minute or two
while the Fedora-8-Test-1-Live-i686 LiveCD runs.


Expected results:
  When System, Preferences, Personal, Assistive Technology Preferences
has the checkbox UNselected (as it is by default when f8 rawhide is 
running), it would be reaonable to expect this process to consume
no CPU resources, instead of the constant 1% ~ 4% CPU consumption
shown by Applications, System Tools, System Monitor.

  When System, Preferences, Personal, Assistive Technology Preferences
has the checkbox selected (as it is by default when the
Fedora-8-Test-1-Live-i686 LiveCD is running), no anonymous window
should be briefly displayed every minute or two.  It would be
reasonable also to expect this process to consume trivial CPU resources
as long as no Assistive Technology is in use.

Additional info:
  When running the LiveCD, killing at-spi-registryd stops
the popup window from periodically appearing.

Two pertinent (possibly factual) comments can be found at:

  http://mail.opensolaris.org/pipermail/desktop-discuss/2006-July/007909.html

The at-spi-registryd process should be started only when
accessibility is enabled. There is (was?) a bug in xscreensaver which
caused at-spi-registryd process to be started when it should not have
been.

    https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=227476
already documents what Powertop reveals about this program's behavior.
Comment 1 Matthias Clasen 2007-08-27 19:54:18 EDT
not an accessibility problem. What you are seeing is the gnome-power-manager
brightness OSD, and the problem has meanwhile been fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.