Bug 25351 - logrotate schedule is bad
logrotate schedule is bad
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: webalizer (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-30 16:59 EST by Florin Andrei
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-30 16:59:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2001-01-30 16:59:25 EST
Right now, on RH 7.0, Webalizer is run after the logrotate for
Apache:

[florin@stantz florin]$ ls -l /etc/cron.daily/
total 32
-rwxr-xr-x    1 root     root          276 Aug  4 02:01 0anacron
-rwxr-xr-x    1 root     root           51 Aug 15 09:30 logrotate
-rwxr-xr-x    1 root     root          402 Aug 23 08:56 makewhatis.cron
-rwxr-xr-x    1 root     root           97 Aug 17 05:29 postfix
-rwxr-xr-x    1 root     root           99 Dec 18 09:15 slocate.cron
-rwxr-xr-x    1 root     root          221 Oct  5 13:41 tmpwatch
-rwxr-xr-x    1 root     root          315 Aug 23 03:30 tripwire-check
-rwxr-xr-x    1 root     root           82 Aug  3  2000 webalizer.cron
[florin@stantz florin]$ ls -l /etc/logrotate.d/
total 36
-rw-r--r--    1 root     root          590 Oct 18 15:31 apache
-rw-r--r--    1 root     root           78 Aug  9 02:55 ftpd
-rw-r--r--    1 root     root          145 Aug 23 16:18 linuxconf
-rw-r--r--    1 root     root          657 Jan 17 02:09 mysql
-rw-r--r--    1 root     root          152 Nov 10 01:50 named
-rw-r--r--    1 root     root          196 Aug 14 12:02 samba
-rw-r--r--    1 root     root          543 Jan 16 14:26 squid
-rw-r--r--    1 root     root          546 Jan 11 15:28 squid.rpmsave
-rw-r--r--    1 root     root          763 Sep 14 11:00 syslog
[florin@stantz florin]$ 

        See? First, /etc/cron.daily/logrotate is run, and this means that
Apache logs are rotated, and only after this webalizer comes. This is
bad, because Webalizer will only find an empty log file.
        I suggest to rename /etc/cron.daily/webalizer.cron to something
like
/etc/cron.daily/0webalizer
Comment 1 Tim Powers 2001-01-31 11:15:47 EST
OK. I have fixed this and it should show up in rawhide the next time rawhide is
updated.

Tim

Note You need to log in before you can comment on or make changes to this bug.