Bug 253532 - pm-utils should check if kernel has upgraded before suspending
pm-utils should check if kernel has upgraded before suspending
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pm-utils (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-20 09:29 EDT by Traxtopel
Modified: 2015-03-04 20:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 12:26:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Traxtopel 2007-08-20 09:29:13 EDT
Description of problem:
RHEL5 system kernel is upgraded
3rd party modules are included on system, are also upgraded.
Machine is suspended
/etc/pm/config.d/unload_modules unloads certain modules i.e. nvidia/fglrx
When machine resumes, it will no longer be able to find certain modules.

pm-utils/gnome-power-manager should check if the kernel has been upgraded and
prevent or warn user from suspending. If suspend/hibernation takes place it may
render machine in a useless resume state.

Version-Release number of selected component (if applicable):


How reproducible:
see above

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Phil Knirsch 2007-08-20 11:19:14 EDT
This will need a bit of work as no current fix is there, but should be doable.
As we are currently already very late for RHEL-5.1.0 it's not sure if we can
include this fix in RHEL-5.1.0, but certainly as soon as possible.

Additionally with our normal and supported update procedure the last 3 kernels
as well as the installed one will always remain on your system, and manually
upgrading and removing the currently running kernel without a reboot can cause
other problems as well (e.g. USB devices and other hotplug related hardware).

Requesting this as a RHEL-5.2 Fastrack bug then.

Read ya, Phil

PS: Maybe we should mark manual upgrades of kernels in the releasenotes
appropriately and mention that a reboot of the system afterwards is highly
recommended?
Comment 3 RHEL Product and Program Management 2007-10-15 23:46:49 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Phil Knirsch 2008-01-10 10:32:50 EST
Unfortunately due to capacity constraints of higher prioritized issues we
currently can't commit to fix this issue in time for the next Red Hat
Enterprise Linux update release.

We will of course still try to address this issue if time and resources are
available before the end of the Development phase or at a future Red Hat
Enterprise Linux update release.

Read ya, Phil
Comment 6 RHEL Product and Program Management 2008-06-02 16:33:33 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Phil Knirsch 2009-03-20 12:26:09 EDT
This request was evaluated by Red Hat Engineering for inclusion in a Red
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat Enterprise
Linux update release for currently deployed products.

The problem we identified was that this would need to be fixed overall for the system instead of for single applications as it affects a large number of applications and services that require unloading and loading modules. Also the standard and recommended way for updates always will leave the currently running kernel installed on the system, which will completely avoid this problem.

With the goal of minimizing risk of change for deployed systems, and in
response to customer and partner requirements, Red Hat takes a conservative
approach when evaluating enhancements for inclusion in maintenance updates
for currently deployed products. The primary objectives of update releases
are to enable new hardware platform support and to resolve critical
defects.

However, Red Hat will further review this request for potential inclusion
in future major releases of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.