Bug 25354 - glms does not work on ABIT KT7-Raid
glms does not work on ABIT KT7-Raid
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: glms (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-30 17:10 EST by Edward Kuns
Modified: 2015-03-04 20:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 07:25:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Kuns 2001-01-30 17:10:06 EST
I have successfully configured the lm_sensors package to see
the sensors on my motherboard.  I added the following to rc.local:

# I2C adapter drivers
#modprobe i2c-viapro
modprobe i2c-isa
# I2C chip drivers
#modprobe adm1021
#modprobe eeprom
modprobe via686a

# Configure the actual sensors
modprobe sensors
sensors -s

The commented out lines were suggested by sensors-detect, but
turned out to provide misleading or wrong information.  With the
lines as above, I can enter the command "sensors" and see:

via686a-isa-6000
Adapter: ISA adapter
Algorithm: ISA algorithm
CPU core:  +1.74 V  (min =  +2.08 V, max =  +2.49 V)   ALARM
I/O:       +3.28 V  (min =  +2.93 V, max =  +3.62 V)   
+5V:       +4.87 V  (min =  +4.75 V, max =  +5.24 V)   
+12V:     +11.57 V  (min = +11.39 V, max = +12.58 V)   
CPU Fan:  4591 RPM  (min =    0 RPM, div = 2)          
P/S Fan:     0 RPM  (min = 3000 RPM, div = 2)          
SYS Temp: +24.60C   (limit = +500C, hysteresis = +600C) 
CPU Temp: +40.50C   (limit = +500C, hysteresis = +600C) 
SBr Temp: +21.50C   (limit = +500C, hysteresis = +600C) 

All of which agree with the values I see in the BIOS.

However, glms displays all temperatures as absolute zero!
(-279 C)  It displays all fan RPMs as zero.  Interestingly
all voltages are also -279.

Running glms_applet from a console, all *appears* to work
OK except for the nonsense readings I see on the applet.
Comment 1 Phil Knirsch 2001-01-31 05:52:18 EST
I'll look into it.

Read ya, Phil
Comment 2 Phil Knirsch 2001-02-05 11:27:01 EST
I've spent some time on it over the weekend. The problem is that glms is
probably no longer actively maintained and therefore has not been updated to the
new lm_sensors 2.5.x style. Therefore the 'fix' would require a complete rewrite
of the backend data aquisiton engine which would take considerable time.

If i happen to have a spare day in the next two weeks i'll fix it, but no
promises here.

I'd rather recommend to use one of the other tools listed on this site:

http://www2.lm-sensors.nu/~lm78/cvs/lm_sensors2/doc/useful_addresses.html

Read ya, Phil
Comment 3 Phil Knirsch 2001-02-07 07:25:41 EST
OK, took some time yesterday and today to get this thing fixed. The whole lm.c
has basically changed and is now using a more general approach to data
aquisition which should work better for most people as it doesn't rely on the
actual chipset anymore.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.