Bug 253603 - s-c-kdump doesn't support new kdump config directives
s-c-kdump doesn't support new kdump config directives
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-kdump (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
:
: 385591 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-20 16:21 EDT by David Lehman
Modified: 2011-01-24 16:54 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0396
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:22:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2007-08-20 16:21:18 EDT
Description of problem:
There no UI for configuration of or even pass-through handling for new config
options "link_delay", "kdump_post", "extra_bins", "extra_modules", or new
default action "halt". At a minimum s-c-kdump should preserve the values it
finds for these options and not display any error messages. A more complete fix
would be the addition of an "Advanced Options" dialog to handle configuration of
these options as well as "core_collector" (and perhaps "path").

Version-Release number of selected component (if applicable):
system-config-kdump-1.0.10-1.el5

How reproducible:
Always

Steps to Reproduce:
1. populate /etc/kdump.conf with the new directives/options described above
2. run system-config-kdump
3.
  
Actual results:
Probably an error message stating that filesystem type $OPTION_NAME is not
supported.

Expected results:
Either quiet preservation of the settings or some UI for their manipulation.

Additional info:
Comment 1 RHEL Product and Program Management 2007-10-15 23:46:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 David Lehman 2007-11-15 16:09:39 EST
*** Bug 385591 has been marked as a duplicate of this bug. ***
Comment 4 David Lehman 2008-01-18 14:43:38 EST
I am going to add the halt default action, since it is trivial to do so. As for
the others, I am just adding code to preserve unknown options so we don't do any
damage.

Fix will be in system-config-kdump-1.0.13-1.el5.
Comment 8 errata-xmlrpc 2008-05-21 13:22:51 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0396.html

Note You need to log in before you can comment on or make changes to this bug.