Bug 253621 - uppercase package name causes dependency failure
uppercase package name causes dependency failure
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Paul Nasrat
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-20 17:43 EDT by Adam Monsen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 17:51:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
specfile for PKG-A, a package with no dependencies and a non-numeric in the release field (454 bytes, text/plain)
2007-08-20 17:43 EDT, Adam Monsen
no flags Details
pkg_b specfile, a package dependent on a specific version and release of PKG-A (505 bytes, text/plain)
2007-08-20 17:45 EDT, Adam Monsen
no flags Details

  None (edit)
Description Adam Monsen 2007-08-20 17:43:50 EDT
Description of problem:
Having an uppercase package name causes a dependency failure when a particular
release is specified in a 'Requires:' field.

Version-Release number of selected component (if applicable):
rpm-4.4.2-46.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Build PKG-A ... rpmbuild --target=noarch -bb PKG-A.spec
2. Install PKG-A RPM ... sudo rpm -ihv /path/to/PKG-A-1.0-A1.noarch.rpm
3. Build pkg_b ... rpmbuild --target=noarch -bb pkg_b.spec
4. Install pkg_b RPM ... sudo rpm -ihv /path/to/pkg_b-1.0-1.noarch.rpm
  
Actual results:
pkg_b installs

Expected results:
RPM reports
"error: Failed dependencies:
	PKG_A = 1.0-A1 is needed by pkg_b-1.0-1.noarch"

Additional info:
* pkg_b requires a specific version and release of PKG-A.

* I set %_topdir and %_tmppath in my ~/.rpmmacros to allow building RPMs by
non-root users.

* Yes, I know that (a) this is a very contrived example and that (b) the Fedora
package naming conventions advise against non-numerics in the release field
except for pre-releases and (c) requiring a particular release of a package
should generally be avoided because is places a dependency on /how/ a package is
built.

* Assuming this is an actual bug, I'm having a hard time where the bug is in the
source code.
Comment 1 Adam Monsen 2007-08-20 17:43:51 EDT
Created attachment 161923 [details]
specfile for PKG-A, a package with no dependencies and a non-numeric in the release field
Comment 2 Adam Monsen 2007-08-20 17:45:05 EDT
Created attachment 161924 [details]
pkg_b specfile, a package dependent on a specific version and release of PKG-A
Comment 3 Adam Monsen 2007-08-20 17:51:35 EDT
Correction: I obviously swapped the Expected and Actual results in the original
post, sorry.

Expected results:
pkg_b installs

Actual results:
RPM reports
"error: Failed dependencies:
	PKG_A = 1.0-A1 is needed by pkg_b-1.0-1.noarch"


Also, here's a link to the section in the package naming guidelines regarding
non-numerics in the Release field:
http://fedoraproject.org/wiki/Packaging/NamingGuidelines#NonNumericRelease


And, UGH! There was just an error in pkg_b.spec. Dang underscores. Sorry for the
whitenoise.

Note You need to log in before you can comment on or make changes to this bug.