Bug 253675 - kdelibs-3.5.7-20 requires libjasper.so.1 but no available
kdelibs-3.5.7-20 requires libjasper.so.1 but no available
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-21 02:21 EDT by George Billios
Modified: 2014-01-21 17:59 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.2.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 15:06:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Billios 2007-08-21 02:21:28 EDT
Description of problem:
Today tried to update the system and even though yum found that kdelibs-3.5.7-20
required kde-filesystem and downloaded it, during the installation of the
updates I was informed that libjasper.so.1 is needed but not available. 

Version-Release number of selected component (if applicable):
kdelibs-3.5.7-20

How reproducible:
Always

Steps to Reproduce:
1.Do yum update
2.Press yes to update to kdelibs-3.5.7-20
3.
  
Actual results:
Complains during installation for libjasper.so.1

Expected results:
If libjasper.so.1 is needed the package that provides it should be installed by yum.

Additional info:

Here is the output from yum update:

Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package alsa-lib-devel.i386 0:1.0.14-3.fc7 set to be updated
---> Package spamassassin.i386 0:3.2.3-1.fc7 set to be updated
---> Package alsa-lib.i386 0:1.0.14-3.fc7 set to be updated
---> Package smartmontools.i386 1:5.37-3.1.fc7 set to be updated
---> Package procps.i386 0:3.2.7-15.fc7 set to be updated
---> Package kdelibs.i386 6:3.5.7-20.fc7 set to be updated
---> Package kdebase.i386 6:3.5.7-13.fc7 set to be updated
--> Processing Dependency: kde-filesystem for package: kdelibs
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package kde-filesystem.noarch 0:3.5-11.fc7 set to be updated
---> Package kdelibs.i386 6:3.5.7-20.fc7 set to be updated

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 alsa-lib                i386       1.0.14-3.fc7     updates           409 k
 alsa-lib-devel          i386       1.0.14-3.fc7     updates           1.4 M
 kdebase                 i386       6:3.5.7-13.fc7   updates            28 M
 kdelibs                 i386       6:3.5.7-20.fc7   updates            17 M
 procps                  i386       3.2.7-15.fc7     updates           210 k
 smartmontools           i386       1:5.37-3.1.fc7   updates           301 k
 spamassassin            i386       3.2.3-1.fc7      updates           1.0 M
Installing for dependencies:
 kde-filesystem          noarch     3.5-11.fc7       updates            15 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       7 Package(s)         
Remove       0 Package(s)         

Total download size: 49 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
--> Populating transaction set with selected packages. Please wait.
---> Package kde-filesystem.noarch 0:3.5-11.fc7 set to be updated
---> Package alsa-lib-devel.i386 0:1.0.14-3.fc7 set to be updated
---> Package spamassassin.i386 0:3.2.3-1.fc7 set to be updated
---> Package alsa-lib.i386 0:1.0.14-3.fc7 set to be updated
---> Package smartmontools.i386 1:5.37-3.1.fc7 set to be updated
---> Package procps.i386 0:3.2.7-15.fc7 set to be updated
---> Package kdelibs.i386 6:3.5.7-20.fc7 set to be updated
---> Package kdebase.i386 6:3.5.7-13.fc7 set to be updated
ERROR with rpm_check_debug vs depsolve:
Package kdelibs needs libjasper.so.1, this is not available.
Complete!
Comment 1 Rex Dieter 2007-08-21 08:15:47 EDT
$repoquery --whatprovides libjasper.so.1
...     
jasper-0:1.900.1-1.fc7.i386

No problem here.  Either a repo problem or yum buglet.

Closing->worksforme.

If problems persist, please either file a new bug against yum or reopen this one
and we'll reassign it.
Comment 2 George Billios 2007-08-22 05:51:59 EDT
Well I have to reopen it since whatever I did resulted in the same error.

Tried to clean yum cache with: yum clean all  and run yum update again and the
same error appears. 

Did: 
$repoquery --whatprovides libjasper.so.1

jasper-0:1.900.1-1.fc7.i386
jasper-0:1.900.1-2.fc7.i386

$repoquery --location jasper

http://download.fedora.redhat.com/pub/fedora/linux/updates/7/i386//jasper-1.900.1-2.fc7.i386.rpm

But it seems that kdelibs doesn't explicitly requires jasper so yum doesn't
include it in the update process. 

Comment 3 Rex Dieter 2007-08-22 07:30:27 EDT
OK, reassigning to yum.
Comment 4 Jeremy Katz 2007-08-22 09:47:31 EDT
Can you provide the output of 'yum -d6 update kdelibs'?
Comment 5 George Billios 2007-08-22 12:04:11 EDT
Sure, here you go:

yum -d6 update kdelibs
Yum Version: 3.2.2
COMMAND: yum -d6 update kdelibs 
Installroot: /
Ext Commands:

   kdelibs
Setting up Update Process
Reading Local RPMDB
Building updates object
Setting up Package Sacks
kagesenshi-compiz         100% |=========================| 1.9 kB    00:00     
livna                     100% |=========================| 2.1 kB    00:00     
fedora                    100% |=========================| 2.1 kB    00:00     
adobe-linux-i386          100% |=========================|  951 B    00:00     
updates-debuginfo         100% |=========================| 1.9 kB    00:00     
fedora-debuginfo          100% |=========================| 1.9 kB    00:00     
updates                   100% |=========================| 1.9 kB    00:00     
lcdfonts-development      100% |=========================|  951 B    00:00     
putting procps in complex update
putting kdelibs in complex update
putting cyrus-sasl in complex update
putting glibc in complex update
putting pm-utils in complex update
putting openssl in complex update
putting libbeagle in complex update
putting cyrus-sasl-md5 in complex update
putting kernel in complex update
putting spamassassin in complex update
putting smartmontools in complex update
putting libbeagle in complex update
putting cyrus-sasl-plain in complex update
putting emerald in complex update
putting alsa-lib in complex update
putting cyrus-sasl-lib in complex update
putting pm-utils in complex update
putting kernel-devel in complex update
putting cyrus-sasl-devel in complex update
putting libbeagle in complex update
putting pm-utils in complex update
putting alsa-lib-devel in complex update
putting kdebase in complex update
processing procps
processing kdelibs
processing cyrus-sasl
processing glibc.i686
processing pm-utils
processing openssl
processing libbeagle
processing cyrus-sasl-md5
processing kernel.i686
processing spamassassin
processing smartmontools
processing libbeagle
processing cyrus-sasl-plain
processing emerald
processing alsa-lib
processing cyrus-sasl-lib
processing pm-utils
processing kernel-devel.i686
processing cyrus-sasl-devel
processing libbeagle
processing pm-utils
processing alsa-lib-devel
processing kdebase
Resolving Dependencies
1187798402.45
--> Running transaction check
---> Package kdelibs.i386 6:3.5.7-20.fc7 set to be updated
Checking deps for kdelibs.i386 6-3.5.7-20.fc7 - u
looking for (u'kde-filesystem', None, (None, None, None)) as a requirement of
kdelibs.i386 6-3.5.7-20.fc7 - u
Searching pkgSack for dep: kde-filesystem
Potential match for kde-filesystem from kde-filesystem - 3.5-11.fc7.noarch
Matched kde-filesystem - 3.5-11.fc7.noarch to require for kde-filesystem
Checking deps for kdelibs.i386 6-3.5.7-9.fc7 - None
looking at kdelibs as a requirement of ('kdewebdev', 'i386', '6', '3.5.7', '1.fc7')
looking at kdelibs as a requirement of ('aquamarine', 'i386', '0', '0.2.1', '1.fc7')
looking at kdelibs as a requirement of ('kde-settings', 'noarch', '0', '3.5',
'30.fc7')
looking at kdelibs as a requirement of ('kde-i18n-Greek', 'noarch', '1',
'3.5.7', '1.fc7')
looking at kdelibs as a requirement of ('kdnssd-avahi', 'i386', '0', '0.1.3',
'0.1.20060713svn.fc6')
looking at kdelibs as a requirement of ('kdebindings', 'i386', '0', '3.5.7',
'1.fc7.1')
looking at kdelibs as a requirement of ('kdepim', 'i386', '6', '3.5.7', '3.fc7')
looking at kdelibs as a requirement of ('kdebase', 'i386', '6', '3.5.7', '0.1.fc7')
looking at kdelibs as a requirement of ('amarok', 'i386', '0', '1.4.6', '2.fc7')
looking at kdelibs as a requirement of ('koffice-libs', 'i386', '0', '1.6.3',
'9.fc7')
# of Deps = 1

Dep Number: 1/1

kdelibs requires: kde-filesystem
--> Processing Dependency: kde-filesystem for package: kdelibs
Requiring package is from transaction set
Resolving for requiring package: kdelibs-3.5.7-20.fc7 in state u
Resolving for requirement: kde-filesystem
Searching pkgSack for dep: kde-filesystem
Potential match for kde-filesystem from kde-filesystem - 3.5-11.fc7.noarch
Matched kde-filesystem - 3.5-11.fc7.noarch to require for kde-filesystem
TSINFO: Marking kde-filesystem - 3.5-11.fc7.noarch as install for kdelibs
processing dep took: 0.009615
miss = 0
conf = 0
CheckDeps = 1
--> Restarting Dependency Resolution with new changes.
---> Loop Number: 2
Restarting Loop
--> Running transaction check
---> Package kdelibs.i386 6:3.5.7-20.fc7 set to be updated
Checking deps for kdelibs.i386 6-3.5.7-20.fc7 - u
looking for (u'kde-filesystem', None, (None, None, None)) as a requirement of
kdelibs.i386 6-3.5.7-20.fc7 - u
Searching pkgSack for dep: kde-filesystem
Potential match for kde-filesystem from kde-filesystem - 3.5-11.fc7.noarch
Matched kde-filesystem - 3.5-11.fc7.noarch to require for kde-filesystem
---> Package kde-filesystem.noarch 0:3.5-11.fc7 set to be updated
Checking deps for kde-filesystem.noarch 0-3.5-11.fc7 - u
looking for (u'filesystem', None, (None, None, None)) as a requirement of
kde-filesystem.noarch 0-3.5-11.fc7 - u

Dependencies Resolved
1187798403.35

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 kdelibs                 i386       6:3.5.7-20.fc7   updates            17 M
Installing for dependencies:
 kde-filesystem          noarch     3.5-11.fc7       updates            15 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 17 M
Is this ok [y/N]: y
Downloading Packages:
using local copy of kdelibs - 6:3.5.7-20.fc7.i386
using local copy of kde-filesystem - 3.5-11.fc7.noarch
Running rpm_check_debug
--> Populating transaction set with selected packages. Please wait.
Member: kdelibs.i386 6-3.5.7-20.fc7 - u
Adding Package kdelibs - 6:3.5.7-20.fc7.i386 in mode u
---> Package kdelibs.i386 6:3.5.7-20.fc7 set to be updated
Member: kdelibs.i386 6-3.5.7-9.fc7 - None
Member: kde-filesystem.noarch 0-3.5-11.fc7 - u
Adding Package kde-filesystem - 3.5-11.fc7.noarch in mode u
---> Package kde-filesystem.noarch 0:3.5-11.fc7 set to be updated
ERROR with rpm_check_debug vs depsolve:
Package kdelibs needs libjasper.so.1, this is not available.
Complete!
Comment 6 Jeremy Katz 2007-09-13 15:06:14 EDT
This should be fixed with yum 3.2.5

Note You need to log in before you can comment on or make changes to this bug.