Bug 25368 - Upgrade problem
Upgrade problem
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-31 00:29 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 11:35:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-31 00:29:14 EST
While upgrading from Redhat 6.2 to 7.0 the installation produce the 
following.  I cannot get the system to boot because of this. HELP!

-------

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1732, in 
doInstall
    self.upgrade)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/lilo.py", line 247, in 
install
    instRoot + '/etc/lilo.conf.rpmsave')
OSError: [Errno 1] Operation not permitted

Local variables in innermost frame:
self: <lilo.LiloConfiguration instance at 8426de8>
fstab: <fstab.GuiFstab instance at 83ae050>
lilo: boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
linear
default=linux

image=/boot/vmlinuz-2.2.14-6.1.1smp
	label=linux
	read-only
	root=/dev/hda5

image=/boot/vmlinuz-2.2.14-6.1.1
	label=linux-up
	read-only
	root=/dev/hda5

perms: 384
upgrade: 1
hdList: <comps.HeaderListFromFile instance at 84a0a80>
instRoot: /mnt/sysimage

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I2
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9

<failed>
Comment 1 Michael Fulbright 2001-01-31 13:22:19 EST
Do you have the emergency boot floppy that the installer allows you to create?
Comment 2 Need Real Name 2001-01-31 14:09:00 EST
Yes, to both your questions.

However, I solved the problem.

Due to security concerns, I had chattr the file /etc/lilo.conf.

chattr +i lilo.conf

so the install script couldn't update the kernel info in /etc/lilo.conf

When I chattr -i lilo.conf and re-upgraded everything seemed to work
alright.

Shame that the install script doesn't check the attributes of the files it
is trying to write to and issue warnings/error messages.

RPM under 6.2. didn't warn about this either.  This was actually where my probs
began.  I was trying to upgrade the kernel.

Cheers!
Craig



Comment 3 Michael Fulbright 2001-02-01 11:35:30 EST
Ok glad you were able to resolve your problem.

Note You need to log in before you can comment on or make changes to this bug.