Bug 253725 - nm-applet segfaults in nmi_dbus_get_network_key_callback
nm-applet segfaults in nmi_dbus_get_network_key_callback
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-21 10:49 EDT by Bryn M. Reeves
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-05 05:40:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2007-08-21 10:49:42 EDT
Description of problem:
I'm reliably getting a segfault from nm-applet when I click a network name in
the applet menu that I have previously saved a key for.

I do not see the segfault when I click a network that has no encryption or that
I have not previously saved a key for.

This seems to be something broken in my gnome keyring - creating a clean account
on the same system gives me a working nm-applet. I've tried clearing out my
keyring and starting again but I'm still seeing the segfault.

Version-Release number of selected component (if applicable):
NetworkManager-0.6.5-9.fc8
NetworkManager-glib-0.6.5-9.fc8
NetworkManager-gnome-0.6.5-9.fc8
NetworkManager-debuginfo-0.6.5-9.fc8
NetworkManager-vpnc-0.6.4-4.fc8

How reproducible:
100% with this account/keyring, 0% with a new account on the same system.

Steps to Reproduce:
1. Log in to the problem account
2. NM connects to the wired network by default
3. Unplug the wired network
4. Click the NM applet icon and choose an encrypted wireless network that has a
key saved for it
  
Actual results:
NM applet disappears. If run in foreground dumps core.

Expected results:
Join network or display key dialog

Additional info:
Backtrace:
#0  nmi_dbus_get_network_key_callback (result=<value optimized out>, 
    found_list=0x0, data=<value optimized out>) at applet-dbus-info.c:117
#1  0x0000003d98c06742 in g_free () from /usr/lib64/libgnome-keyring.so.0
#2  0x0000003d98c07af6 in g_free () from /usr/lib64/libgnome-keyring.so.0
#3  0x0000003d8762ef13 in g_main_context_dispatch ()
   from /lib64/libglib-2.0.so.0
#4  0x0000003d8763220d in g_free () from /lib64/libglib-2.0.so.0
#5  0x0000003d8763251a in g_main_loop_run () from /lib64/libglib-2.0.so.0
#6  0x0000003d8c75ad43 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#7  0x00000000004096a1 in main (argc=<value optimized out>, 
    argv=<value optimized out>) at main.c:67
#8  0x0000003d8521dd58 in __libc_start_main () from /lib64/libc.so.6
#9  0x0000000000409519 in _start ()
Comment 1 Bryn M. Reeves 2007-08-21 10:53:34 EDT
Let me know if there's additional info needed here - I'm a bit reluctant to
attach cores/keyrings as public attachments.
Comment 2 Dan Williams 2007-08-21 11:27:02 EDT
could you install:

glib2-debuginfo
gtk2-debuginfo
NetworkManager-debuginfo
gnome-keyring-debuginfo

Thanks,
Dan
Comment 3 Bryn M. Reeves 2007-08-21 11:34:48 EDT
Duh. Sorry, only had NM-debuginfo installed. Here's a better backtrace:

#0  nmi_dbus_get_network_key_callback (result=<value optimized out>,
found_list=0x0, data=<value optimized out>) at applet-dbus-info.c:117
#1  0x0000003d98c06742 in find_items_reply (op=0x7f3020) at gnome-keyring.c:2004
#2  0x0000003d98c07af6 in operation_io (io_channel=<value optimized out>,
cond=G_IO_IN, callback_data=<value optimized out>) at gnome-keyring.c:539
#3  0x0000003d8762ef13 in IA__g_main_context_dispatch (context=0x668540) at
gmain.c:2061
#4  0x0000003d8763220d in g_main_context_iterate (context=0x668540, block=1,
dispatch=1, self=<value optimized out>) at gmain.c:2694
#5  0x0000003d8763251a in IA__g_main_loop_run (loop=0x6bec80) at gmain.c:2898
#6  0x0000003d8c75ad43 in IA__gtk_main () at gtkmain.c:1144
#7  0x00000000004096a1 in main (argc=<value optimized out>, argv=<value
optimized out>) at main.c:67
#8  0x0000003d8521dd58 in __libc_start_main () from /lib64/libc.so.6
#9  0x0000000000409519 in _start ()
Comment 4 Bryn M. Reeves 2007-11-05 05:40:25 EST
Not been able to reproduce this since test3 - closing NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.