Bug 253776 - [s390] boot from NSS support
[s390] boot from NSS support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
s390x Linux
high Severity high
: rc
: ---
Assigned To: Hans-Joachim Picht
Red Hat Kernel QE team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-21 16:39 EDT by Brad Hinson
Modified: 2014-07-24 23:37 EDT (History)
9 users (show)

See Also:
Fixed In Version: kernel-2.6.32
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:45:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 38023 None None None Never

  None (edit)
Description Brad Hinson 2007-08-21 16:39:27 EDT
Description of problem:
Request to add support for booting from an NSS (Named Saved Segment).  This
allows multiple guests running under z/VM to use the read-only sections of the
kernel in a shared memory space.  Posted to lkml here:

http://lkml.org/lkml/2007/1/26/186

IBM DeveloperWorks link:

http://www.ibm.com/developerworks/linux/linux390/useful_add-ons_nss-v1.html
Comment 1 IBM Bug Proxy 2007-08-21 19:00:40 EDT
------- Comment From mranweil@us.ibm.com 2007-08-21 18:52 EDT-------
Opened by Brad Hinson (bhinson@redhat.com) 	on 2007-08-21 16:39 EST 	[reply]
Comment 2 IBM Bug Proxy 2007-08-22 11:20:32 EDT
------- Comment From mgrf@de.ibm.com 2007-08-22 11:16 EDT-------
Brad opened this bugzilla based on a customer request Red Hat is working with.

Adding Martin and Heiko for kernel
Comment 3 IBM Bug Proxy 2007-09-24 09:25:25 EDT
------- Comment From mgrf@de.ibm.com 2007-09-24 09:20 EDT-------
Hello Red Hat:
There has been no answer nor position yet to Reinhards statement and question!
(In reply to comment #13)
> Hi Brad,
> so far we did not intend to suggest the boot from NSS patch to RHEL 5.x.
> The reason being that the current patch only addresses the problem of booting
> a monolytical kernel from an NSS. Yet RHEL uses a highly modularized kernel
+
> initramfs. I we do not yet have a realy good solution to resolve this.
> Feel free to have a close look at the patch on developerworks. If you have
an
> idea what needs to be done for RHEL to benefit from that patch let us know.
> If you think the patch (as is) should got in to RHEL 5.x please confirm.
> Then we can drive it into our plans.

Your action required:
For a customer request
=> please ask the customer to open a FITs requirement against IBM.
This will support to get this new request into our plans

If any question the IBM representative can help to open a FITs

------- Comment From mgrf@de.ibm.com 2007-09-24 09:20 EDT-------
Hello Red Hat:
There has been no answer nor position yet to Reinhards statement and question!
(In reply to comment #13)
> Hi Brad,
> so far we did not intend to suggest the boot from NSS patch to RHEL 5.x.
> The reason being that the current patch only addresses the problem of booting
> a monolytical kernel from an NSS. Yet RHEL uses a highly modularized kernel
+
> initramfs. I we do not yet have a realy good solution to resolve this.
> Feel free to have a close look at the patch on developerworks. If you have
an
> idea what needs to be done for RHEL to benefit from that patch let us know.
> If you think the patch (as is) should got in to RHEL 5.x please confirm.
> Then we can drive it into our plans.

Your action required:
For a customer request
=> please ask the customer to open a FITs requirement against IBM.
This will support to get this new request into our plans

If any question the IBM representative can help to open a FITs
Comment 4 Brad Hinson 2007-09-26 11:10:11 EDT
Looking back over my past email, I see that Richard Lewis from IBM requested
this.  I'll contact him now with the information in comment 3.
Comment 5 Peter Martuccelli 2007-11-05 11:45:50 EST
IBM has NAKd this request as they feel it is not very useful for RHEL.  Brad if
you disagree then explain the benefits of including the change in R5 for IBM to
reconsider.
Comment 6 RHEL Product and Program Management 2007-11-05 11:52:51 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 7 Brad Hinson 2008-06-19 11:46:37 EDT
Reopening for possible RHEL 6 consideration.
Comment 8 Bill Nottingham 2008-10-10 13:14:37 EDT
If it still requires a static kernel, it's still not very useful for RHEL.
Comment 9 RHEL Product and Program Management 2009-02-05 18:32:35 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 10 Gonzalo Muelas Serrano 2009-12-10 11:05:53 EST
Bill N.,
what do you mean with static kernel requirement?
This feature has been already implemented in RHEL 5.4, see RH Bug # 474646

Thank you,
Gonzalo.
Comment 11 Bill Nottingham 2009-12-10 13:44:07 EST
It was referring to comment #3; if this wasn't useful in a highly modularized kernel, it wouldn't seem useful for RHEL. Then again, it didn't appear it would *hurt* anything, either.
Comment 14 Hendrik Brueckner 2010-01-13 03:24:35 EST
RHEL6 includes support for creating and booting from NSS. The NSS support is upstream as of kernel version 2.6.21.

See also the upstream patch at:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=fe355b7f1c7400cbb71762a1237461be03f88265
Comment 22 releng-rhel@redhat.com 2010-11-10 15:45:49 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.
Comment 23 IBM Bug Proxy 2010-11-11 13:42:05 EST
------- Comment From mjr@linux.vnet.ibm.com 2010-11-11 13:34 EDT-------
RH bug is closed, do same here.

Note You need to log in before you can comment on or make changes to this bug.