Bug 253908 - vdso patch probably fixing the "useless traces" issue
vdso patch probably fixing the "useless traces" issue
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-22 16:44 EDT by Andre Klapper
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-26 16:24:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Klapper 2007-08-22 16:44:56 EDT
90% of the traces we get on bugzilla.gnome.org from fedora 7/8 are pretty
useless and miss symbols, even if required debug packages are installed. we get
tons of them[1], it triggers lots of work and makes identifying cardinal issues
really hard. (for completeness: this is not only a fedora and opensuse issue,
also debian2.18 and ubuntu suffer from this.)

https://bugzilla.novell.com/show_bug.cgi?id=258433#c43 lists a potential kernel
fix in the opensuse repository for this.

setting priority and severity to "urgent" after talking to mbarnes.

--
[1] for example
http://bugzilla.gnome.org/show_bug.cgi?id=426807
http://bugzilla.gnome.org/show_bug.cgi?id=426227
http://bugzilla.gnome.org/show_bug.cgi?id=433922
Comment 1 Chuck Ebbert 2007-08-22 18:17:17 EDT
Patch is in 2.6.22.5-rc1, just added to F7 kernel CVS.
Comment 2 Chuck Ebbert 2007-08-22 18:34:03 EDT
In kernel-2.6.22.4-66.fc7, building now.
Comment 3 Dave Jones 2007-08-27 11:08:53 EDT
I'm puzzled by this.   I don't understand why this would be a problem for
Fedora, given we don't enable the compat vdso.

I'm wondering if there's a secondary problem here, that is perhaps caused by
something else. Roland?
Comment 4 Roland McGrath 2007-08-27 16:31:01 EDT
Those three gnome bug reports show backtraces that appear perfectly correct from
the vDSO to its caller (waitpid).  This clearly has nothing to do with the
"allow debuggers access to vDSO" issue (even if that applied to Fedora kernels),
because the debugger clearly does have access to the vDSO or else it would not
know the name "__kernel_vsyscall" or be able to unwind from there.

There is no indication that this is a kernel issue at all.  The only kind of
thing that is even dimly related to the kernel I can imagine relating to this is
if the vDSO unwind info for __kernel_vsyscall or for the signal trampoline is
wrong or incomplete.  What little information was supplied suggests those are
perfectly fine, since unwinding worked to get a sane caller.  

All I see in those examples is that apparently some gnome libraries either have
incomplete debug info or have incorrect unwind info.

Note You need to log in before you can comment on or make changes to this bug.