Bug 253964 - [HTS5][all Arch] - gnome-terminal Test Result after HTS test showing wrong sometimes
[HTS5][all Arch] - gnome-terminal Test Result after HTS test showing wrong so...
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
All Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-23 05:31 EDT by Satyabrata Maitra
Modified: 2008-07-16 17:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 04:15:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-terminal-test result-status (62.92 KB, image/png)
2007-08-23 05:35 EDT, Satyabrata Maitra
no flags Details
results.xml (130.91 KB, text/xml)
2007-08-23 05:36 EDT, Satyabrata Maitra
no flags Details
plan.xml (1.54 KB, text/xml)
2007-08-23 05:37 EDT, Satyabrata Maitra
no flags Details
output.log for core (4.66 KB, text/plain)
2007-08-23 05:37 EDT, Satyabrata Maitra
no flags Details
ia64-xen-all-tests-log-and-results (89.63 KB, application/x-gzip)
2007-09-19 04:12 EDT, Satyabrata Maitra
no flags Details

  None (edit)
Description Satyabrata Maitra 2007-08-23 05:31:13 EDT
Description of problem:
When test for the HTS5 for any arch, sometimes the Test Rresult showing after
any particular test is completed, sometimes wrong. For example, when tested for
ia64-xen system, for hts-core, in gnome-terminal, its showing PASS after test is
complete, but if open the results.xml file and observe, it can be seen that the
test is actually FAIL. all the g-t screensshot, results.xml, plan.xml,
output.log file is attached here with this bug. Not only Core, its happening for
other tests too for other archs or the same arch. It includes, network, usb,
memory, storage, cdrom testing.

Version-Release number of selected component (if applicable):
hts-5.0.50.el5

How reproducible:
Always

Steps to Reproduce:
1. Install the required rpm for hts, and its dependent packages, and follow the
hts5 testing steps.
2. Observe the Test result status (PASS or FAIL), showing n gnome-terminal after
each test is completed.
3. Open results.xml, file, and see the test result status (PASS or FAIL)
  
Actual results:
The test result in both places are not with the same status.

Expected results:

The test result in both places should be with same status.

Additional info:
required Files attached to trace the bug.
Comment 1 Satyabrata Maitra 2007-08-23 05:35:13 EDT
Created attachment 168444 [details]
gnome-terminal-test result-status
Comment 2 Satyabrata Maitra 2007-08-23 05:36:21 EDT
Created attachment 168447 [details]
results.xml
Comment 3 Satyabrata Maitra 2007-08-23 05:37:03 EDT
Created attachment 168449 [details]
plan.xml
Comment 4 Satyabrata Maitra 2007-08-23 05:37:40 EDT
Created attachment 168451 [details]
output.log for core
Comment 5 Satyabrata Maitra 2007-08-23 05:43:16 EDT
And prticularly ia64-xen system is giving traceback error in g-t for each tests.
Traceback error is shown in the screenshot in comment #1. pls see and suggest
any seperate bug needed for this or can mention in this bug iteslf!.
Comment 6 Greg Nichols 2007-09-17 20:39:13 EDT
The attachments only indicate this problem for the info test.   Can you provide
test results showing incorrect reporting for any other tests?

Thanks!
Comment 7 Satyabrata Maitra 2007-09-19 03:56:33 EDT
Hi Greg
Test results got from "hts-submit" is attached in Comment #2. I think you want
output.log file for the other hardware components like network, memory, usb,
etc, apart from core, which is attached on Comment #4. right? If so, please let
me  run these tests once again, to collect the files. I will attach those file
once test finishes. Can make it by tomorrow! :)
Comment 8 Satyabrata Maitra 2007-09-19 04:12:36 EDT
Created attachment 199361 [details]
ia64-xen-all-tests-log-and-results

Hi Greg
I collected the entire results, log files for hts on this ia64-xen system. Its
attached right here. Its having a directory namely 'run' under which there are
log files for each of the tests.
Comment 9 Greg Nichols 2007-10-03 20:43:07 EDT
The only test that shows failures indicated as PASS is the info test.   This is
fixed in HTS 5.1 R3.
Comment 10 Yan Tian 2007-11-01 04:15:21 EDT
g-t show PASS of info test, not show RESULT of COMPONENT test. `hts print` or
`cat /var/log/hts/runs/NUM/COMPONENT/output.log` could show the RESULT of
COMPONENT. 

Think this is not a bug, resolve it.

Note You need to log in before you can comment on or make changes to this bug.