This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 253992 - backport maketreeinfo.py
backport maketreeinfo.py
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Joel Andres Granados
FutureFeature
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-23 10:07 EDT by Dennis Gregorovic
Modified: 2008-05-21 11:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:31:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dennis Gregorovic 2007-08-23 10:07:59 EDT
Newer versions of anaconda-runtime contain a script called maketreeinfo.py that
generates a .treeinfo file describing the contents of a tree.  This would be
useful for RHEL 5 trees.
Comment 2 RHEL Product and Program Management 2007-10-15 23:45:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Joel Andres Granados 2007-11-12 08:33:37 EST
Tested with the x86 arch.  This means that the scripts/mk-images.x86 correctly
created the .treeinfo file.  The other scripts, I have not tested.
Comment 5 James Laska 2008-01-08 11:29:06 EST
Looking great!

$ cat /mnt/redhat/nightly/RHEL5.2-Server-20080108.nightly/5/i386/os/.treeinfo 
[general]
family = RHEL
timestamp = 1199774959.166056
variant = Server
totaldiscs = 0
packagedirs = Server,VT,Cluster,ClusterStorage
version = 5.2
arch = i386


Would it be possible to change the family to "Red Hat Enterprise Linux" ?

Comment 6 James Laska 2008-01-08 11:47:21 EST
Additionally ... would it be possible to carry the [images-*] sections from
Fedora into RHEL ... those are the meat of the .treeinfo. 

For example ...

http://porkchop.redhat.com/released/F-8/GOLD/Fedora/i386/os/.treeinfo
http://porkchop.redhat.com/released/F-8/GOLD/Fedora/ppc/os/.treeinfo
http://porkchop.redhat.com/released/F-8/GOLD/Fedora/x86_64/os/.treeinfo

contain content similar to ...

[general]
family = Fedora
timestamp = 1194015227.78
variant = Fedora
totaldiscs = 1
version = 8
discnum = 1
packagedir = Packages
arch = i386

[images-i386]
kernel = images/pxeboot/vmlinuz
initrd = images/pxeboot/initrd.img
boot.iso = images/boot.iso
diskboot.img = images/diskboot.img

[images-xen]
kernel = images/xen/vmlinuz
initrd = images/xen/initrd.img

[stage2]
instimage = images/minstg2.img
mainimage = images/stage2.img
Comment 7 Joel Andres Granados 2008-01-09 10:31:13 EST
I made the mk-XXXX image changes but forgot to actually add the maketreeinfo.py
script.  It should be working now as it works in fedora. :)
Comment 8 James Laska 2008-01-21 15:54:28 EST
As of anaconda-11.1.2.88-1 (RHEL5.2-Server-20080121.nightly) the .treeinfo file
does not appear correctly:

http://porkchop.redhat.com/nightly/RHEL5.2-Server-20080121.nightly/tree-x86_64/.treeinfo

I have modified a previous .treeinfo file to include the missing [images-*]
sections.  For example, see:

http://porkchop.redhat.com/nightly/RHEL5.2-Server-20080118.nightly/tree-x86_64/.treeinfo
Comment 9 Joel Andres Granados 2008-01-22 06:04:06 EST
> 
> Would it be possible to change the family to "Red Hat Enterprise Linux" ?
> 
^^^^ this depends on how buildinstall is called.  To have the desired behavior
you must call buildinstall with --family="Red Hat Enterprise Linux" :)  This
would be an issue for the people that compose rhel. :)
Comment 10 Joel Andres Granados 2008-01-22 06:21:24 EST
Think I know whats causing the problem.  I need to know what the version of RHEL
used to compose RHEL5.2 (I would assume 5.1) and the exact version of anaconda
used in this system.
I think that the buildinstall is not using the new mk-images.### and is using
the ones that are already in the system.
Comment 11 Joel Andres Granados 2008-01-22 06:55:27 EST
Can we confirm that the system that is composing has intalled 11.1.2.88 and not
11.1.2.87 ?
Comment 12 James Laska 2008-01-22 07:27:55 EST
> > Would it be possible to change the family to "Red Hat Enterprise Linux" ?

> ^^^^ this depends on how buildinstall is called.  To have the desired behavior
> you must call buildinstall with --family="Red Hat Enterprise Linux" :)  This
> would be an issue for the people that compose rhel. :)

That's not so much a problem ... the bigger issue is the missing [images-*]
sections.

> Can we confirm that the system that is composing has intalled 11.1.2.88 and
not 11.1.2.87 ?

Adding dgregor (RHEL5 release engineering) to the cc list.  

Dennis, we are trying to debug a compose-time issue dealing with the version of
anaconda used to generate the .treeinfo file.  Can you provide some pointers?
Comment 15 Joel Andres Granados 2008-01-24 05:02:34 EST
Checked the status on todays nightly, it seems to have created the required
sections.  FYI there is a section missing (the stage2 section).  It will be
visible once anaconda 89 is out :)  changing to modified.
Comment 17 James Laska 2008-01-25 07:45:29 EST
http://porkchop.redhat.com/nightly/RHEL5.2-Server-20080124.nightly/tree-ppc/.treeinfo

Looks like [stage2] needs to use the relative path?

[stage2]
instimage = images/minstg2.img
mainimage = images/stage2.img

 ... instead of ...

[stage2]
instimage =
/mnt/redhat/nightly/RHEL5.2-Server-20080124.nightly/work/ppc-global/images/minstg2.img
mainimage =
/mnt/redhat/nightly/RHEL5.2-Server-20080124.nightly/work/ppc-global/images/stage2.img

Comment 18 Daniel Mach 2008-01-25 08:08:45 EST
I think there should be more than one packagedir.

packagedir = Server/RPMS
should be
packagedir = Server,Cluster,ClusterStorage (and VT for some arches)

please note that there's no RPMS subdir in packagedirs
Comment 19 Joel Andres Granados 2008-01-25 10:34:20 EST
(In reply to comment #17)
>
http://porkchop.redhat.com/nightly/RHEL5.2-Server-20080124.nightly/tree-ppc/.treeinfo
> 
> Looks like [stage2] needs to use the relative path?
> 
> [stage2]
> instimage = images/minstg2.img
> mainimage = images/stage2.img
> 
>  ... instead of ...
> 
> [stage2]
> instimage =
>
/mnt/redhat/nightly/RHEL5.2-Server-20080124.nightly/work/ppc-global/images/minstg2.img
> mainimage =
>
/mnt/redhat/nightly/RHEL5.2-Server-20080124.nightly/work/ppc-global/images/stage2.img
> 
> 
fixed
Comment 21 Joel Andres Granados 2008-01-27 10:58:41 EST
As discussed in #anaconda, made respective changes:
1. Corrected the packagedir
2. added repodata
3. erased variant for now
4. makes a list of packagedirs

Did not test, lets wait for next anaconda build.
Comment 23 James Laska 2008-01-29 07:26:26 EST
[general] section missing from Client nightly

http://porkchop.redhat.com/nightly/RHEL5.2-Client-20080129.nightly/5/i386/os/.treeinfo
 - Missing [general] section
 - contains anaconda-11.1.2.92-1

From
/mnt/redhat/nightly/RHEL5.2-Client-20080129.nightly/logs/i386-logs/distill-RHEL5.2-Client-20080129.nightly-i386.log

Writing .treeinfo file...
--variant missing, but that's OK.
--discnum missing; assuming disc 1
--totaldiscs missing; assuming 1
Traceback (most recent call last):
  File
"/mnt/redhat/nightly/RHEL5.2-Client-20080129.nightly/work/i386-global/buildinstall.tree.19565/maketreeinfo.py",
line 103, in ?
    f = open(data["outfile"], "r+")
IOError: [Errno 2] No such file or directory:
'/mnt/redhat/nightly/RHEL5.2-Client-20080129.nightly/work/i386-global/.treeinfo'


http://porkchop.redhat.com/nightly/RHEL5.2-Server-20080129.nightly/5/i386/os/.treeinfo
 - [stage2] using incorrect paths
 - contains anaconda-11.1.2.90-1

The latest anaconda-11.1.2.92-1 appears to be missing the [general] section.

Moving back to assigned

Comment 24 Joel Andres Granados 2008-01-29 07:34:26 EST
(In reply to comment #23)
> [general] section missing from Client nightly
> 
> 
^^^ this has already been addressed.

> 
> Moving back to assigned
> 
> 
moving back to modified.

And to correct my previous post the build is on:
http://porkchop.redhat.com/brewroot/scratch/jgranado/task_1138585
Comment 25 Joel Andres Granados 2008-01-29 10:04:00 EST
I should really wait until the porkchop builds are completely done.  sorry for
the noise.
http://porkchop.redhat.com/brewroot/scratch/jgranado/task_1138830/
Comment 27 James Laska 2008-01-30 08:34:52 EST
Moving back to MODIFIED ... a fix is in CVS but is not included in an official
build.  When the fix lands in a package that is included in the errata, we can
move this to ON_QA.
Comment 31 James Laska 2008-01-31 07:35:53 EST
All .treeinfo files look perfect in anaconda-11.1.2.93-1 for i386, ia64, 

$ cat /mnt/redhat/nightly/RHEL5.2-Server-20080131.nightly/tree-i386/.treeinfo

[general]
repodata = Server/repodata
family = Red Hat Enterprise Linux Server
timestamp = 1201764350.05
totaldiscs = 1
version = 5
discnum = 1
packagedir = Server
arch = i386

[images-i386]
kernel = images/pxeboot/vmlinuz
initrd = images/pxeboot/initrd.img
boot.iso = images/boot.iso
diskboot.img = images/diskboot.img

[images-xen]
kernel = images/xen/vmlinuz
initrd = images/xen/initrd.img

[stage2]
instimage = images/minstg2.img
mainimage = images/stage2.img
Comment 32 Joel Andres Granados 2008-01-31 07:48:55 EST
Looking good :).
One thing bothers me though.  the fact that repodata and packagedir only have
one entry.  I coded so these variables could be a list of values.  I think this
is due to the fact that distill does not execute the way I thought or Maybe
buildinstall  creates .treeinfo in a temp file and then puts it in the final tree.
Comment 34 errata-xmlrpc 2008-05-21 11:31:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html

Note You need to log in before you can comment on or make changes to this bug.