Bug 254053 - Missing Obsoletes: setarch, Provides: setarch deps
Missing Obsoletes: setarch, Provides: setarch deps
Status: CLOSED DUPLICATE of bug 253969
Product: Fedora
Classification: Fedora
Component: util-linux-ng (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-23 16:13 EDT by Daniel Berrange
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 07:05:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2007-08-23 16:13:32 EDT
Description of problem:
When attempting to update to latest rawhide

Transaction Check Error:
  file /usr/bin/i386 from install of util-linux-ng-2.13-0.57.fc8 conflicts with
file from package setarch-2.0-4.fc7
  file /usr/bin/linux32 from install of util-linux-ng-2.13-0.57.fc8 conflicts
with file from package setarch-2.0-4.fc7
  file /usr/bin/linux64 from install of util-linux-ng-2.13-0.57.fc8 conflicts
with file from package setarch-2.0-4.fc7
  file /usr/bin/setarch from install of util-linux-ng-2.13-0.57.fc8 conflicts
with file from package setarch-2.0-4.fc7
  file /usr/bin/x86_64 from install of util-linux-ng-2.13-0.57.fc8 conflicts
with file from package setarch-2.0-4.fc7
  file /usr/share/man/man8/setarch.8.gz from install of
util-linux-ng-2.13-0.57.fc8 conflicts with file from package setarch-2.0-4.fc7

As far as I can see, util-linux-ng  contains a copy of every file that's in
setarch, so util-linux-ng should have deps to Obsolete & Provide  'setarch' so
that upgrades work without file clashes.

Version-Release number of selected component (if applicable):
setarch-2.0-4.fc7
util-linux-ng-2.13-0.57.fc8

How reproducible:
Always

Steps to Reproduce:
1. Install setarch
2. Attempt to update to util-linux-ng
3.
  
Actual results:
File clash

Expected results:
setarch is replaced by util-linux-ng

Additional info:
Comment 1 Ignacio Vazquez-Abrams 2007-08-24 07:05:22 EDT

*** This bug has been marked as a duplicate of 253969 ***

Note You need to log in before you can comment on or make changes to this bug.