Bug 254124 - libgnome-devel should Require: popt-devel
libgnome-devel should Require: popt-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgnome (Show other bugs)
rawhide
All Linux
high Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-24 06:27 EDT by Paul Howarth
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 10:28:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2007-08-24 06:27:30 EDT
/usr/include/libgnome-2.0/libgnome/gnome-program.h has:

#include <popt.h>

So libgnome-devel should have a dependency on the package providing this file,
namely popt-devel.

It would be good to get this fix in ASAP so that the popt-devel buildreq is
pulled in for most gnome apps that are going to need it (many of which are being
rebuilt for the F8 mass rebuild at the moment) without needing any spec changes
for those apps.
Comment 1 Ray Strode [halfline] 2007-08-24 10:28:00 EDT
Matt fixed half of this problem last night, and Chris fixed the other half this
morning

Note You need to log in before you can comment on or make changes to this bug.