Bug 254236 - Can you add /etc/skel/.mozilla do your spec file
Can you add /etc/skel/.mozilla do your spec file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
FF3RawhideClose
: Reopened
Depends On:
Blocks: 427307 427308
  Show dependency treegraph
 
Reported: 2007-08-24 17:42 EDT by Daniel Walsh
Modified: 2008-01-07 02:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 13:00:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2007-08-24 17:42:10 EDT
Description of problem:

This would greatly help the labeling of homedirectories at creation and allow us
to do some cool stuff with SELinux.
Comment 1 Daniel Walsh 2007-08-24 17:43:14 EDT
Also can we change the default for downloads to Download, which now exists in Gnome?
Comment 2 Christopher Aillon 2007-08-26 17:46:04 EDT
need to first test to make sure that having a blank .mozilla directory won't
hurt anything.
Comment 3 Matěj Cepl 2007-12-20 11:46:37 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays
Comment 4 Daniel Walsh 2007-12-31 11:44:59 EST
Could you do this for the rawhide version.
Comment 5 Christopher Aillon 2007-12-31 12:19:23 EST
(In reply to comment #2)
> need to first test to make sure that having a blank .mozilla directory won't
> hurt anything.

Firefox 3 is able to create a profile with a blank dir... seems doable.  Are
equivalent bugs filed against both seamonkey and thunderbird as well?
Comment 6 Christopher Aillon 2007-12-31 13:00:21 EST
Fixed in firefox-3.0-0.beta2.4.fc9
Comment 7 Kai Engert (:kaie) 2008-01-07 02:08:24 EST
In firefox.spec, you added this line to the %files section:

  %{_sysconfdir}/skel/.mozilla


Shouldn't that be the following?

  %dir %{_sysconfdir}/skel/.mozilla

Note You need to log in before you can comment on or make changes to this bug.