Bug 254237 - Please add /etc/skel/gnome2 and /etc/skel/Download as an empty directory.
Please add /etc/skel/gnome2 and /etc/skel/Download as an empty directory.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgnome (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-24 17:46 EDT by Daniel Walsh
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 09:31:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2007-08-24 17:46:20 EDT
Description of problem:

Currently libgnome creates both of these directories the first time they are
needed, but SELInux can not handle the labeling of them, when this happens,
since it is not know which application creates them.  If they are in the skel
they will get labeled correctly.

This will allow us to do some cool things with SELinux and controling users.
Comment 1 Ignacio Vazquez-Abrams 2007-08-24 17:49:55 EDT
I agree with gnome2, but Download is created dynamically by xdg-user-dirs and
has a localized name.
Comment 2 Daniel Walsh 2007-08-27 09:08:34 EDT
Ok, well the .gnome2 is good enough.
Comment 3 Ray Strode [halfline] 2007-08-27 09:31:39 EDT
okay, building now

Note You need to log in before you can comment on or make changes to this bug.