Bug 25430 - amanda-client needs to have a /etc/xinetd.d/amandad file
Summary: amanda-client needs to have a /etc/xinetd.d/amandad file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: amanda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-31 22:16 UTC by Seth Vidal
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-31 23:55:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Seth Vidal 2001-01-31 22:16:47 UTC
amanda-client does not have an /etc/xinetd.d/amandad file and it needs to
otherwise amanda-client will not work.

Add this file, please.

Comment 1 Trond Eivind Glomsrxd 2001-01-31 22:27:04 UTC
The "amandad" program is run from the "amanda" file.

Comment 2 Seth Vidal 2001-01-31 22:31:30 UTC
when I installed amanda and amanda-client I don't have the daemon entry to
start the client software as I need - so something is not right.
the correct entry looks like this

# default: off
# description:  The client for the Amanda backup system.\
#               This must be on for systems being backed up\
#               by Amanda.

service amanda
{
        disable = no
        socket_type             = dgram
        protocol                = udp
        wait                    = yes
        user                    = operator
        group                   = disk
        server                  = /usr/lib/amanda/amandad
}


that is what is needed for the amanda-client to work


Comment 3 Seth Vidal 2001-01-31 22:36:10 UTC
/usr/lib/amanda/amandad
/usr/lib/amanda/calcsize
/usr/lib/amanda/killpgrp
/usr/lib/amanda/patch-system
/usr/lib/amanda/rundump
/usr/lib/amanda/runtar
/usr/lib/amanda/selfcheck
/usr/lib/amanda/sendbackup
/usr/lib/amanda/sendsize
/usr/lib/amanda/versionsuffix
/usr/lib/libamclient-2.4.2.so
/usr/lib/libamclient.so
/usr/sbin/amrecover
/usr/sbin/security
/usr/share/man/man8/amrecover.8.gz


file list for amanda-client - should have /etc/xinetd.d/amanda in there
it doesn't.



Comment 4 Trond Eivind Glomsrxd 2001-01-31 22:51:56 UTC
Hmm... it's part of amanda-server. It would probably make sense to move it to
amanda-client... agreed?

Comment 5 Seth Vidal 2001-01-31 22:56:10 UTC
yes - that keeps me from having to install amanda-server on my backup'd clients.

thanks

y'all are responding incredibly fast and I really appreciate it.


Comment 6 Trond Eivind Glomsrxd 2001-01-31 23:05:39 UTC
amandaidx on client or server?

Comment 7 Seth Vidal 2001-01-31 23:55:04 UTC
idx should be in server.



Comment 8 Trond Eivind Glomsrxd 2001-02-01 00:08:31 UTC
Should be fixed in 2.4.2-3, building now, coming soon to a Rawhide near you.


Note You need to log in before you can comment on or make changes to this bug.