Bug 254301 - rarian-compat doesn't output omf directory
rarian-compat doesn't output omf directory
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rarian (Show other bugs)
rawhide
i686 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-25 11:19 EDT by Christopher Brown
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-30 12:13:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to revert omfdir changes (347 bytes, patch)
2007-08-25 11:19 EDT, Christopher Brown
no flags Details | Diff
This patch reverts rarian behaviour to scrollkeeper behaviour (412 bytes, patch)
2007-08-26 21:55 EDT, Christopher Brown
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 12212 None None None Never

  None (edit)
Description Christopher Brown 2007-08-25 11:19:08 EDT
Description of problem:

The rarian-compat package includes a shell script called rarian-sk-config which
attempts to mimic scrollkeeper-config output. However the following command:

rarian-sk-config --omfdir

returns nothing whereas with

scrollkeeper-config --omfdir

from the scrollkeeper package, not the rarian-compat package the correct output
is returned, namely

/usr/share/omf

The above causes my package build to fail

http://koji.fedoraproject.org/koji/getfile?taskID=126996&name=build.log

The traditional method of obtaining the omf directory in scrollkeeper was simply:

echo $datadir/omf

Version-Release number of selected component (if applicable):

rarian-compat-0.5.8-1.fc8

How reproducible:

Always

Steps to Reproduce:
1. install rarian from development/rawhide
2. run rarian-sk-config --omfdir
3. 
  
Actual results:

nothing

Expected results:

/usr/share/omf

Additional info: Attaching patch which reverts to old method though I suspect
there is a reason for the new code...
Comment 1 Christopher Brown 2007-08-25 11:19:08 EDT
Created attachment 172561 [details]
Patch to revert omfdir changes
Comment 2 Christopher Brown 2007-08-26 21:55:19 EDT
Created attachment 173201 [details]
This patch reverts rarian behaviour to scrollkeeper behaviour

New patch generated from source, obsoleting previous
Comment 3 Christopher Brown 2007-08-29 06:47:03 EDT
This is now urgent as I am unable to build for F8 T2 as it currently stands.
Comment 4 Matthew Barnes 2007-08-30 12:13:34 EDT
I added your patch to rarian-0.5.8-3.fc8 so that you're able to build again. 
Apologies for the delay.

Looks like this bug has already been reported upstream, so I'm moving this
upstream with a cross-reference to your patch.  See [1] for further updates.

[1] http://bugs.freedesktop.org/show_bug.cgi?id=12212

Note You need to log in before you can comment on or make changes to this bug.