Bug 25439 - Gnome-core needs to require specific version of gnome-libs
Summary: Gnome-core needs to require specific version of gnome-libs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Mason
QA Contact: David Lawrence
URL:
Whiteboard: Florence RC-1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-01 00:00 UTC by Göran Uddeborg
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 21:12:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Göran Uddeborg 2001-02-01 00:00:29 UTC
The package gnome-core 1.2.1 should require a gnome-libs version high
enough.  I haven't researched the precise version, but 1.2.8 is high
enough, while 1.0.54 was too low.  (I would guess the critical number is
the step to 1.2, but that's just a guess.)  I upgraded only the gnome-core
package on a system with otherwise old versions of gnome.  The autmatic
library dependencies were fulfilled; rpm had no objections.  But when
trying to run gnome-session, an error message resulted:

/usr/bin/gnome-session: error while loading shared libraries:
/usr/bin/gnome-session: undefined symbol:
gnome_window_icon_set_default_from_file

and the session then aborted.

Comment 1 Glen Foster 2001-02-01 19:59:24 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #1

Comment 2 Elliot Lee 2001-02-01 21:12:10 UTC
From what I can gather, gnome-libs 1.0.61 was the first one to have
gnome-window-icon.c in it. I will gnome-libs 1.2.0 as a requirement for our
gnome-core package.


Note You need to log in before you can comment on or make changes to this bug.