Bug 25443 - switching profiles: changing IP not restarting net
Summary: switching profiles: changing IP not restarting net
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-01 02:14 UTC by Joe Harrington
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-02-21 18:47:53 UTC


Attachments (Terms of Use)

Description Joe Harrington 2001-02-01 02:14:55 UTC
When switching profiles from home to office, activating the changes
restarts xinetd but not the network, so the IP isn't updated.  This worked
in RH 6.2.

linuxconf-1.19r2-4

--jh--

Comment 1 Joe Harrington 2002-03-08 16:28:25 UTC
Hey this is still a problem in 7.2!  How come nobody's looking at it?  It's been
over a *year* this has sat here untouched.

The problem is that /etc/rc.d/init.d/network reload is what's run by linuxconf,
but that doesn't change the IP address.  You have to do a restart to get that to
happen.  (or, it's a bug in /etc/rc.d/init.d/network that reload doesn't do it,
but in that case please just  reassign this bug to that component.  I don't know
which is the case.)

linuxconf-1.25r7-3

--jh--


Comment 2 Brent Fox 2002-06-05 16:19:46 UTC
Closing because we don't ship linuxconf anymore

Comment 3 Red Hat Bugzilla 2006-02-21 18:47:53 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.