Bug 254841 - continuous restarting of dbus-daemon and gnome-vfs-daemon processes after performing a graphical login
continuous restarting of dbus-daemon and gnome-vfs-daemon processes after per...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
7
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-26 06:47 EDT by Roland Hermans
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 14:40:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Hermans 2007-08-26 06:47:45 EDT
Description of problem:
After performing a graphical login using gdm the top and bottom gnome-panels are
displayed but empty and the gnome-volume-manager reports a crash. I can use the
mouse and keyboard to close the bugbuddy window, but am not able to launch any
application since the menus and icons on the gnome-panels are not available.

Version-Release number of selected component (if applicable):
e2fsprogs-libs 1.40.2-2.fc7

How reproducible:
always

Steps to Reproduce:
1. Login as a normal user via gdm
2.
3.
  
Actual results:
unable to use the desktop

Expected results:
fully functional desktop with initialized gnome-panels

Additional info:
The desktop does not respond due to the continuous restarting of the user's
dbus-daemon and gnome-vfs-daemon processes. When I kill the user's dbus-daemon
process, the login procedure continues and the desktop is usable again.

The problem first occurred after updating the system on Aug 25, 2007 with yum
and then rebooting the system. I checked the shared libraries on which
gnome-vfs-daemon depends and the only updated package was e2fsprogs-libs. After
reverting e2fsprogs, e2fsprogs-devel and e2fsprogs-libs to version 1.39-11 the
problem no longer occurs.
Comment 1 Roland Hermans 2007-08-26 07:36:06 EDT
Actually I'm not sure which component is most appropriate for this bug. The
problem occurred after upgrading e2fsprog-libs but it is very well possible that
the real problem is in dbus-1.0.2-6.fc7 or gnome-vfs2-2.18.1-4.fc7.
Comment 2 Eric Sandeen 2007-08-29 01:26:43 EDT
Ok, now that's odd. So simply downgrading e2fprogs solves it - and you didn't
make any other changes?  You're fairly certain that the bug only shows up with
the new e2fsprogs and not the old?

can you start dbus-daemon by hand outside of gnome and possibly gather a core
file or error messages? 

(sorry, this bug went wayward on assignment somehow, so didn't see it for a few
days)
Comment 3 Eric Sandeen 2007-08-29 01:40:28 EDT
libcom_err is the library you see that gnome-vfs-daemon depends on?  I'll look
at what changed...

-Eric
Comment 4 Eric Sandeen 2007-08-29 01:55:56 EDT
putting the gnome-vfs2 & dbus folks on cc: just in case...
Comment 5 Eric Sandeen 2007-08-29 17:37:57 EDT
I did a fresh install of F7, and applied all updates, including
e2fsprogs-1.40.2, on i686 today... local user logs in, no problems, dbus-daemon
and gnome-vfs-daemon are both running happily.

Any chance you can gather more information from the daemons you see having
trouble?  either messages, cores, strace... something?

Thanks,

-Eric
Comment 6 Eric Sandeen 2007-09-19 14:40:36 EDT
Another person in the office also applied these updates w/o incident... w/o more
information, or a way to reproduce this, closing as WORKSFORME.  Please re-open
(with more info, if possible) if it gets hit again.

Thanks,

-Eric
Comment 7 Roland Hermans 2007-09-19 17:20:24 EDT
Sorry for not responding earlier to your requests. For some reason I did not
receive any Bugzilla mails on this bug until you changed the status of this bug.

Before I reported the bug I checked that I could reproduce the problem even
after reverting to e2fsprogs-1.39, rebooting, reinstalling e2fsprogs-1.40.2 and
rebooting again (all without making any other changes to the system). Something
must have changed on my system between reporting this bug and today since when I
tried upgrading to e2fsprogs-1.40.2 today it all seems to work fine.

Actually it may have been hardware/BIOS related as about a week after reporting
the bug I got a CMOS checksum error at boot due to a failing CMOS battery. I
replaced the battery and reloaded default BIOS settings.

Anyway, I agree to close this bug as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.