Bug 25496 - Invalid sendmail[13162]: error: safesasl after RHN update
Summary: Invalid sendmail[13162]: error: safesasl after RHN update
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-01 17:07 UTC by Network Administrator
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 17:57:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Network Administrator 2001-02-01 17:07:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


After a recent upgrade from Red Hat Network to sendmail, I started getting 
the following errors:
Feb  1 07:29:06 lexx sendmail[13162]: error: safesasl
(/usr/lib/sasl/Sendmail.conf) failed: World writable directory
Feb  1 07:29:06 lexx sendmail[13162]: error: safesasl
(/usr/lib/sasl/libanonymous.so) failed: World writable directory
Feb  1 07:29:06 lexx sendmail[13162]: error: safesasl
(/usr/lib/sasl/libcrammd5.so) failed: World writable directory
Feb  1 07:29:06 lexx sendmail[13162]: error: safesasl
(/usr/lib/sasl/libdigestmd5.so) failed: World writable directory
Feb  1 07:29:06 lexx sendmail[13162]: error: safesasl
(/usr/lib/sasl/liblogin.so) failed: World writable directory
Feb  1 07:29:06 lexx sendmail[13162]: error: safesasl
(/usr/lib/sasl/libplain.so) failed: World writable directory

The /usr/lib/sasl/ is NOT world writable, and is set as:
drwxr-xr-x    2 root     root         4096 Jan 31 10:13 sasl

These settings have not been changed from what Red Hat installed.

Reproducible: Always
Steps to Reproduce:
None needed. Seems to happen every time any kind of sendmail action takes 
place.
	

Actual Results:  I get the error message. Unable to tell if is actually 
impacting the operation of Sendmail. Mail delivery seems to be happening 
normally.

Expected Results:  I shouldn't be getting bogus error messages in my log.

It is running on a dual PIII 700Mhz server with 256MB of RAM. This same 
server also is running Apache with various modules. As I said, I wasn't 
getting this error until the most recent set of security updates/bug fixes 
from Red Hat Network.

Comment 1 Florian La Roche 2001-02-07 11:48:24 UTC
Is /usr or /usr/lib world writable?





Comment 2 Network Administrator 2001-02-07 17:57:00 UTC
Well, that was it. For some reason- /usr/lib was set to owner/group ftp and was 
world writable. Sounds like a really bad default setting somewhere, as I didn't 
change it. I set it to owner/group root 755. Could this have been changed by 
the RHN update agent? I'll report if I continue to get any errors, but I 
suspect that is it.


Note You need to log in before you can comment on or make changes to this bug.