This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 254981 - X cannot display at full resolution
X cannot display at full resolution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-26 08:55 EDT by Josh Boyer
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-26 19:28:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log from today's boot (51.31 KB, text/plain)
2007-08-26 08:55 EDT, Josh Boyer
no flags Details
Broken xorg.conf with this xorg-x11 (870 bytes, application/octet-stream)
2007-08-26 11:31 EDT, Josh Boyer
no flags Details

  None (edit)
Description Josh Boyer 2007-08-26 08:55:43 EDT
Description of problem:

Latest xorg-x11 in rawhide cannot display on my laptop at 1680x1050.  This
worked just fine before updating yesterday.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.3.0.0-22.fc8
xorg-x11-drv-ati-6.7.191-1.fc8

How reproducible:

Always

Steps to Reproduce:
1.  Boot laptop into X
2.  See resolution not at 1680x1050
3.
  
Actual results:

Resolution is at 1360x768

Expected results:

Resolution is at 1680x1050

Additional info:

The laptop is a Thinkpad z60m with a Radeon Mobility x600 graphics card.  This
has worked at full resolution (1680x1050) since pre-F7.

smolt profile: 

http://smolt.fedoraproject.org/show?UUID=63cc2d27-4185-4cc2-bae6-87042b715610
Comment 1 Josh Boyer 2007-08-26 08:55:43 EDT
Created attachment 172961 [details]
Xorg.0.log from today's boot
Comment 2 Josh Boyer 2007-08-26 11:31:16 EDT
Created attachment 173021 [details]
Broken xorg.conf with this xorg-x11

I tried manually selecting "Generic LCD 1680x1050" with system-config-display. 
This xorg.conf file represents that attempt.  That resulted in me getting a
nice black screen with no GDM login screen, etc.

Then I renamed xorg.conf to xorg.conf.broken and restarted X.  This resulted
back to having the resolution at 1360x768, but no /etc/X11/xorg.conf exists...
Comment 3 Josh Boyer 2007-08-26 11:32:01 EDT
Oh, and... REGRESSION! ;)
Comment 4 Josh Boyer 2007-08-26 14:32:47 EDT
I believe the previous working versions were:

xorg-x11-server-Xorg.i386 1.3.0.0-20.fc8
xorg-x11-drv-ati.i386 6.6.193-2.fc8

according to my yum logs.
Comment 5 Dave Airlie 2007-08-26 18:32:26 EDT
please test the latest driver from rawhide 6.7.191-2
http://koji.fedoraproject.org/koji/buildinfo?buildID=16342
Comment 6 Josh Boyer 2007-08-26 18:53:54 EDT
Works like a charm.  Back to good 'ol 1680x1050.  Dave, you are my hero.

Note You need to log in before you can comment on or make changes to this bug.