Bug 25513 - Missing via686a module
Summary: Missing via686a module
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lm_sensors   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-01 19:36 UTC by mark
Modified: 2015-03-05 01:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 19:36:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mark 2001-02-01 19:36:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686; Nav)


via686a module is missing from the RPM. Source RPM is of v2.5.0, regular
RPM is of v2.5.2, so compilation from source RPM proceeds but module
insertion fails due to non-matching symbols.

Reproducible: Always
Steps to Reproduce:
1. Install lm_sensors-2.5.2-3 and lm_sensors-devel-2.5.2-3
2.  ls /lib/modules/2.2.16-22/misc/*via*
(part 2)
How it was discovered:
/usr/sbin/sensors-detect on an Asus A7V motherboard.  
followed by  modprobe via686a


Actual Results:  The module didn't appear in the listing. 
(part 2)
If you follow the default prompts in sensors-detect, it will produce this
output near the end:
Driver `w83781d' (should be inserted):
  Detects correctly:
  * Bus `SMBus vt82c596 adapter at e800' (Non-I2C SMBus adapter)
    Busdriver `i2c-viapro', I2C address 0x2d (and 0x48 0x49)
    Chip `Asus AS99127F' (confidence: 8)

Driver `via686a' (should be inserted):
  Detects correctly:
  * ISA bus, undetermined address (Busdriver `i2c-isa')
    Chip `VIA Technologies VT 82C686 Integrated Sensors' (confidence: 9)

After the sensors-detect script exitted, modprobe via686a returned:
modprobe: Can't locate module via686a

Expected Results:  The module should have been found and loaded

Comment 1 Phil Knirsch 2001-02-05 13:58:50 UTC
Fixed in the new 2.4 kernel RPM release.


Note You need to log in before you can comment on or make changes to this bug.