Bug 25554 - long suspends mess up display
long suspends mess up display
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-01 17:45 EST by Joe Harrington
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 14:26:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v (2.57 KB, text/plain)
2001-03-23 14:08 EST, Joe Harrington
no flags Details
lspci -vn (1.93 KB, text/plain)
2001-03-23 14:09 EST, Joe Harrington
no flags Details
XF86config-4 (3.62 KB, text/plain)
2001-03-23 14:10 EST, Joe Harrington
no flags Details

  None (edit)
Description Joe Harrington 2001-02-01 17:45:32 EST
When I suspend my laptop for short periods, it's fine.  If I suspend for
several hours, the following happens:

A region of the display is moved from near the bottom to the top of the
display.  The region is 1" high and runs the width of the display.  Usually
for me it contains a chunk of a gnome-terminal, but not always.

Keyboard input goes to the window under the mouse (I have pointer focus),
even if it is being displayed elsewhere.

Other items on the screen are "shadows of themselves".  Essentially, all
the window backgrounds appear.  Occasionally cursor outlines appear, but
never text.  They never change, even if the window is typed in or exited
from.  They stay on screen even if switching to another desktop.

This all happens even if I turn CHANGEVT=7 on in /etc/sysconfig/apmd
(changes vt to 1 before suspend, back after).

This is on a Toshiba Tecra 8000, RH7.0, XF86 4.0.1 as released and updated.

--jh--
Comment 1 Mike A. Harris 2001-03-18 13:58:23 EST
What video hardware does it have in it?

Also, please attach all of the following:

lspci -v
lspci -vn

Your XF86Config-4 and your X server logs from after an incident occurs.
Give as much info as possible.
Comment 2 Joe Harrington 2001-03-23 14:08:56 EST
Created attachment 13463 [details]
lspci -v
Comment 3 Joe Harrington 2001-03-23 14:09:37 EST
Created attachment 13464 [details]
lspci -vn
Comment 4 Joe Harrington 2001-03-23 14:10:59 EST
Created attachment 13465 [details]
XF86config-4
Comment 5 Joe Harrington 2001-03-23 14:26:29 EST
This problem completely went away when I updated to sawfish-0.36-2.

Since that might just mean that it's a server bug that's no longer being
tickled, here's the requested info:
 
Neomagic NM2200 rev 18

Output of  lspci -v and  lspci -vn is attached, as is my XF86config-4 file. 
Server logs I can't do, as it's been a while since I reported or had this
problem.  Sorry...

I'm marking this WORKAROUND, since it looks like a server bug (should the window
manager be *able* to leave the display in this condition) and I haven't changed
server packages.  If you feel differently, feel free to change the status as
appropriate.

--jh--

Note You need to log in before you can comment on or make changes to this bug.