Bug 255761 - Fedora 7 xen doesn't run on Asus L3400 Tp laptop, ends in kernel panic
Fedora 7 xen doesn't run on Asus L3400 Tp laptop, ends in kernel panic
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
7
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-26 23:27 EDT by Orca Lonsdale
Modified: 2009-12-14 15:38 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.21-6.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 15:49:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mkinitrd.log as requested (6.51 KB, text/plain)
2007-09-26 00:08 EDT, Orca Lonsdale
no flags Details

  None (edit)
Description Orca Lonsdale 2007-08-26 23:27:10 EDT
Description of problem:
After installation of Fedora 7 on Asus L3400Tp laptop, including virtualisation
with the xen-package during the install. After installation by default Fedora
(2.6.20-2925.13.fc7xen) is started but ends in a kernel panic, saying

mount:
could not find file system '/dev/root' 
setuproot: moving /dev failed: No such file or directory 
setuproot: error mounting /procs: No such file or directory 
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory 
Kernel panic - Not syncing: Attempted to kill init!

Version-Release number of selected component (if applicable):
xen.gz-2.6.20-2925.13.fc7
vmlinuz-2.6.20-2925.13.fc7xen
initrd-2.6.20-2925.13.fc7xen.img

How reproducible:
Use the /etc/grub.conf part that's created during Fedora 7's install as:
title Fedora (2.6.20-2931.fc7xen)
	root (hd0,0)
	kernel /boot/xen.gz-2.6.20-2931.fc7
	module /boot/vmlinuz-2.6.20-2931.fc7xen ro root=LABEL=/ rhgb quiet
	module /boot/initrd-2.6.20-2931.fc7xen.img

Steps to Reproduce:
1. Install Fedora 7, including virtualisation, on Asus L3400Tp laptop
2. Startup
3.
  
Actual results:
Kernel Panic and restart

Expected results:
Fedora running with Xen

Additional info:
Also the newest Fedora 2.6.20-2931.fc7xen with kernel
/boot/xen.gz-2.6.20-2931.fc7, vmlinuz-2.6.20-2931.fc7xen and
initrd-2.6.20-2931.fc7xen.img show this behaviour.
Comment 1 Eduardo Habkost 2007-09-25 11:13:16 EDT
What is the version of your mkinitrd package? Could you ensure you have the 
latest mkinitrd package and regenerate your initrd file with the command:

mkinitrd -f /boot/initrd-2.6.20-2931.fc7xen.img 2.6.20-2931.fc7xen


Testing with the latest kernel-xen on F-7 updates (currently 2.6.20-2934.fc7, 
that is being pushed right now) is welcome, too. Ensure you have the latest 
mkinitrd package before installing the new kernel-xen.


If the problem persists when using the latest mkinitrd, please attach to this 
bug the /tmp/mkinitrd.log file generated by running:

mkinitrd -v -f /boot/initrd-2.6.20-2931.fc7xen 2.6.20-2931.fc7xen 
> /tmp/mkinitrd.log 2>&1

Please also paste the output of:

# ls -l /sys/block/*/device/driver


This way, we can check if the needed kernel modules are really being included 
on the initrd image for kernel-xen.
Comment 2 Eduardo Habkost 2007-09-25 11:19:12 EDT
(In reply to comment #1)
> 
> Please also paste the output of:
> 
> # ls -l /sys/block/*/device/driver

Ignore this command, it will not show the most relevant modules that are 
needed. Please paste the output of 'lsmod' under the non-xen kernel on this 
machine, instead.
Comment 3 Orca Lonsdale 2007-09-26 00:08:57 EDT
Created attachment 206381 [details]
mkinitrd.log as requested
Comment 4 Orca Lonsdale 2007-09-26 00:11:42 EDT
# mkinitrd --version
mkinitrd: version 6.0.9
from yum updates repo: mkinitrd-6.0.9-7.1.i386.rpm 	14-Jun-2007 11:14

After running as root
mkinitrd -f /boot/initrd-2.6.20-2931.fc7xen.img 2.6.20-2931.fc7xen
and rebooting, the problem persisted.

F7 kernel-xen 2.6.20-2934.fc7 not yet available through yum update, so not tried
yet.

# ls -l /sys/block/*/device/driver
lrwxrwxrwx 1 root root 0 2007-09-26 04:05 /sys/block/sda/device/driver ->
../../../../../../bus/scsi/drivers/sd
lrwxrwxrwx 1 root root 0 2007-09-26 04:09 /sys/block/sr0/device/driver ->
../../../../../../bus/scsi/drivers/sr

# lsmod
Module                  Size  Used by
ipt_MASQUERADE          7745  1 
iptable_nat            11461  1 
nf_nat                 22381  2 ipt_MASQUERADE,iptable_nat
nf_conntrack_ipv4      15049  3 iptable_nat
xt_state                6593  1 
nf_conntrack           63049  5
ipt_MASQUERADE,iptable_nat,nf_nat,nf_conntrack_ipv4,xt_state
nfnetlink               9945  3 nf_nat,nf_conntrack_ipv4,nf_conntrack
ipt_REJECT              8641  2 
xt_tcpudp               7233  4 
iptable_filter          7105  1 
ip_tables              16517  2 iptable_nat,iptable_filter
x_tables               18629  6
ipt_MASQUERADE,iptable_nat,xt_state,ipt_REJECT,xt_tcpudp,ip_tables
bridge                 53977  0 
irnet                  26849  0 
ppp_generic            30677  1 irnet
slhc                   10049  1 ppp_generic
irtty_sir              10305  0 
sir_dev                18373  1 irtty_sir
ircomm_tty             26953  0 
ircomm                 17349  1 ircomm_tty
autofs4                24773  2 
hidp                   26689  2 
tun                    14913  0 
sunrpc                161981  1 
rfcomm                 44377  0 
l2cap                  30401  10 hidp,rfcomm
bluetooth              57893  5 hidp,rfcomm,l2cap
dm_mirror              25153  0 
dm_multipath           21961  0 
dm_mod                 57089  2 dm_mirror,dm_multipath
video                  21065  0 
sbs                    22729  0 
button                 12113  0 
dock                   13921  0 
battery                14149  0 
ac                      9285  0 
ipv6                  277957  28 
snd_intel8x0m          20813  1 
snd_intel8x0           36061  2 
snd_ac97_codec         96613  2 snd_intel8x0m,snd_intel8x0
ac97_bus                6465  1 snd_ac97_codec
snd_seq_dummy           7877  0 
snd_seq_oss            33473  0 
snd_seq_midi_event     11073  1 snd_seq_oss
snd_seq                50609  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         11981  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            43457  0 
snd_mixer_oss          19521  3 snd_pcm_oss
snd_pcm                74949  4
snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
nsc_ircc               21713  0 
parport_pc             30821  0 
snd_timer              24901  2 snd_seq,snd_pcm
firewire_ohci          20801  0 
snd                    53317  12
snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
irda                  118009  5 irnet,sir_dev,ircomm_tty,ircomm,nsc_ircc
8139cp                 26433  0 
crc_ccitt               6337  1 irda
firewire_core          43137  1 firewire_ohci
parport                38281  1 parport_pc
8139too                29249  0 
rtc_cmos               12001  0 
soundcore              11681  3 snd
i2c_sis96x              9413  0 
snd_page_alloc         13769  3 snd_intel8x0m,snd_intel8x0,snd_pcm
crc_itu_t               6337  1 firewire_core
mii                     9409  2 8139cp,8139too
serio_raw              10821  0 
i2c_core               27841  1 i2c_sis96x
sr_mod                 20837  0 
floppy                 58661  0 
cdrom                  37089  1 sr_mod
joydev                 13825  0 
sg                     37469  0 
pata_sis               17733  3 
ata_generic            11589  0 
libata                117809  2 pata_sis,ata_generic
sd_mod                 31297  4 
scsi_mod              140749  4 sr_mod,sg,libata,sd_mod
ext3                  125513  2 
jbd                    59881  1 ext3
mbcache                12485  1 ext3
ehci_hcd               35405  0 
ohci_hcd               23877  0 
uhci_hcd               27089  0 


Comment 5 Orca Lonsdale 2007-09-27 12:19:36 EDT
Kernel 2.6.20-2934.fc7 has arrived. 
Ran
# mkinitrd -f /boot/initrd-2.6.20-2934.fc7xen.img 2.6.20-2934.fc7xen
and rebooted. Result is the same kernel panic.
Comment 6 Orca Lonsdale 2007-11-13 00:22:52 EST
Solution: Upgrade to Fedora 8! (Works for me :)
Thanks
Comment 7 Eduardo Habkost 2007-11-13 06:03:33 EST
Fedora 7 kernel-xen will be upgraded to 2.6.21.7 soon, on updates-testing. As 
this is the same kernel-xen version currently on Fedora 8 and Rawhide, it 
should solve the problem for Fedora 7 also.
Comment 8 Orca Lonsdale 2007-11-13 07:24:30 EST
I understand, thanks. However, I will not be able to test it for you as I'm on a
slow '3rd world country' internet connection, which makes any upgrade over the
internet (I have no DVD-writer) a tedious and error-prone process as there are
also frequent power black-outs, sorry.
Comment 9 Fedora Update System 2007-11-14 22:36:23 EST
kernel-xen-2.6-2.6.21-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel-xen-2.6'
Comment 10 Fedora Update System 2007-11-28 20:34:33 EST
kernel-xen-2.6-2.6.21-6.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel-xen-2.6'
Comment 11 Fedora Update System 2007-12-06 15:49:16 EST
kernel-xen-2.6-2.6.21-6.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.