Bug 25610 - inetd-0.16-7 generates syslog messages
inetd-0.16-7 generates syslog messages
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: inetd (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-01 21:31 EST by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-03 17:13:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-01 21:31:13 EST
the new inetd-0.16-7 update generates syslog messages such
as the following:

Feb  1 16:11:33 twinlark inetd[424]: pid 2333: exit status 127
Feb  1 16:11:33 twinlark inetd[424]: pid 1642: exit status 1
Feb  1 16:11:37 twinlark inetd[424]: pid 451: exit status 1

this is new as of this upgrade... and it doesn't seem to
be terribly useful.  if inetd would also log what it spawned
for each of these pids then it could be useful to know the
exit code.  otherwise this seems like a debugging message that
maybe got left in... and should be removed.

-dean
Comment 1 Pekka Savola 2001-02-02 18:29:22 EST
For what it's worth, I have been getting these for a long time, long before updating inetd...
Comment 2 Trond Eivind Glomsrxd 2001-02-02 18:50:15 EST
Can you find what pids it spawned in /var/log/secure?  (I don't have any 6.2
boxes around here right now...)
Comment 3 Pekka Savola 2001-02-02 19:03:56 EST
All of these (I checked about 6-7 of them, about one or two a day) were ipop3d.

Using:

imap-2000-2.6

Notes:  the client giving exit status 1 uses the service about 50-100 times for every exit.  He's using a 
microsoft mailer, probably messenger.  There are some people using RHL52 fetchmail to access ipop3d, who
haven't shown the symptoms, but the use is relatively less, so...
Comment 4 Trond Eivind Glomsrxd 2001-02-03 17:08:25 EST
What I meant to ask was: Can you from information in one of the log files find
out what server maps to which pid?
Comment 5 Pekka Savola 2001-02-03 17:13:21 EST
Perhaps I don't still understand the question, but all 'exit 1' messages I had, 
have come from ipop3d (based on /var/log/secure and messages pids).
Comment 6 Trond Eivind Glomsrxd 2001-02-03 17:25:44 EST
OK, as I understand it you can then match the exit status from "messages" with
the pids from "secure". Then it's useful debugging info - closing.
Comment 7 Need Real Name 2001-02-03 17:28:27 EST
it sounds like this message is new as of some changes after rh6.2 --
'cause i wasn't seeing the log message before whatever version of inetd
was "most recent" on 6.2 prior to this bugfix.

regarding ipop3d -- if that wasn't tcp wrapped you wouldn't have a
/var/log/secure entry ... if the inetd log message contained a port
number that'd be sufficient for making it handle wrapped and unwrapped
services.
Comment 8 Trond Eivind Glomsrxd 2001-02-03 17:31:02 EST
It's not new - there are only two changes in that RPM, the "don't leak file
handles patch" from pekkas and "spell RETVAL correctly" in the init script.

Comment 9 Brian Bothwell 2001-02-23 18:20:31 EST
I am still getting tons of the following:

Feb 23 14:32:59 gonzo inetd[21492]: pid 5962: exit signal 13
Feb 23 14:33:03 gonzo inetd[21492]: pid 7123: exit status 1
Feb 23 14:33:09 gonzo inetd[21492]: pid 7125: exit status 1
Feb 23 14:33:17 gonzo inetd[21492]: pid 7130: exit status 1
Feb 23 14:33:22 gonzo inetd[21492]: pid 7132: exit status 1
Feb 23 14:33:27 gonzo inetd[21492]: pid 7133: exit status 1
Feb 23 14:33:33 gonzo inetd[21492]: pid 7134: exit status 1
Feb 23 14:33:38 gonzo inetd[21492]: pid 7135: exit status 1
Feb 23 14:33:43 gonzo inetd[21492]: pid 7136: exit status 1
Feb 23 14:33:48 gonzo inetd[21492]: pid 7137: exit status 1
Feb 23 14:33:54 gonzo inetd[21492]: pid 7138: exit status 1
Feb 23 14:33:58 gonzo inetd[21492]: pid 7139: exit status 1
Feb 23 14:34:02 gonzo inetd[21492]: pid 7140: exit status 1
Feb 23 14:34:08 gonzo inetd[21492]: pid 7141: exit status 1
Feb 23 14:34:15 gonzo inetd[21492]: pid 7142: exit status 1
Feb 23 14:35:27 gonzo inetd[21492]: pid 2184: exit signal 13

These are all from imapd.

This started the day I upgraded to inetd-0.16-7 (I have been running
imap-2000-2.6 for many months)


How is this not a bug??

thanks,

-Brian
Comment 10 Brian Bothwell 2001-02-23 18:22:01 EST
I should note that many of our Outlook IMAP users have reported weird hanging
and slowdowns that seemed to have started after the upgrade to inetd-0.16-7

-Brian
Comment 11 Brian Bothwell 2001-03-08 19:48:15 EST
Does anyone check this?

Comment 12 Pekka Savola 2001-03-09 01:52:11 EST
I've gotten that too, after and before upgrades, but I haven't heard any
complaints about it.

This appears to be debugging information (inetd.c):
---
  	          if (debug) {
                        fprintf(stderr, "pid %d, exit status %x\n", pid,   
  	                          status);
  	        }
---
Comment 13 Trond Eivind Glomsrxd 2001-03-09 11:02:50 EST
I don't see logging non-zero exit codes as a bug in inetd - if you're not
interested, don't look for them or tell syslog not to care.

Note You need to log in before you can comment on or make changes to this bug.