Bug 256161 - setroubleshoot-server: Requires: libxml2-python
setroubleshoot-server: Requires: libxml2-python
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
7
All All
medium Severity low
: ---
: ---
Assigned To: John Dennis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 07:34 EDT by Rex Dieter
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: setroubleshoot-*1.10.1-1.fc7.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 11:59:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2007-08-27 07:34:48 EDT
looks like setroubleshoot-server is missing a
Requires: libxml2-python.

$ rpm -q setroubleshoot-server libxml2-python
setroubleshoot-server-1.9.4-2.fc7
package libxml2-python is not installed

$ service setroubleshoot start
Starting setroubleshootd:                                  [  OK  ]
[root@math-130 ~]# Traceback (most recent call last):
  File "/usr/sbin/setroubleshootd", line 71, in <module>
    from setroubleshoot.server import RunFaultServer
  File "/usr/lib/python2.5/site-packages/setroubleshoot/server.py", line 35, in
                       <module>
    from setroubleshoot.analyze import *
  File "/usr/lib/python2.5/site-packages/setroubleshoot/analyze.py", line 35, in
                       <module>
    from setroubleshoot.avc_audit import *
  File "/usr/lib/python2.5/site-packages/setroubleshoot/avc_audit.py", line 35,
                       in <module>
    from setroubleshoot.signature import AVC, AvcContext
  File "/usr/lib/python2.5/site-packages/setroubleshoot/signature.py", line 75,
                       in <module>
    import libxml2
ImportError: No module named libxml2

After manually installing python-libxml2, the setroubleshoot server service
starts fine.
Comment 1 John Dennis 2007-08-27 11:59:39 EDT
Thank you for reporting this. It was previously fixed, currently available in
setroubleshoot-*1.10.1-1.fc7.noarch.rpm (in the process of being pushed)

Note You need to log in before you can comment on or make changes to this bug.