Bug 25633 - Installer hangs when system booted with USB Logitech Mouseman Wheel
Installer hangs when system booted with USB Logitech Mouseman Wheel
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 01:42 EST by Bill Vinson
Modified: 2007-04-18 12:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 15:50:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Vinson 2001-02-02 01:42:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0 i686; en-US; m18) Gecko/20010128


The mouse is a Logitech Mouseman Wheel M-BA47 and when it is hooked up via
a USB connection the Mouse/keyboard will be unresponsive on first display
of the RedHat logo in the installer.  Then the screen allowing language
selection appears to be hung... No keyboard/mouse input functions.  If
mouse is connected via USB -> PS2 adapter then the installer will function
properly.

Reproducible: Always
Steps to Reproduce:
1.Plug in mouse via USB
2.Boot off of CD taking defaults by hitting ENTER at LILO screen
3.Wait for freeze in GUI
Comment 1 Michael Fulbright 2001-02-02 14:10:52 EST
Does the TAB key move the selection around the display?

There is a known problem in Fisher with detecting some USB mice.  If this is the
problem then it is fixed in our internal CVS.
Comment 2 Glen Foster 2001-02-02 18:13:11 EST
We (Red Hat) should really fix this before next release.
Comment 3 Bill Vinson 2001-02-02 20:13:07 EST
Is there anything I can help do to verify that it is fixed?
I can download a new ISO or I work about 2 minutes from RedHat NC if that would
help?
Comment 4 Kevin Pulliam 2001-02-03 10:53:01 EST
I also have this problem. (I would point out that this bug is not indexed (at
least I couldn't find it) under the install program or any of it's derivitives
for this Fisher Beta.)
I am using a Logitech USB mouse, M/N M-BE58 so this is not confined to a single
Logitech USB mouse product.
Yes, the Installer freezes completely. Tab does not work for movement of focus
or any of that stuff. I had to reboot with the powerbutton ( I imagine reset
would work too, but the power button is easier for me to hit <grin>)
The mouse is detected earlier in the install process as a ps2 mouse, generic, 3
button. (I don't recall if the scroll part was detected) so info is getting
through, it's just not being implimented properly.
At first I thought this might be the broken USB from the 2.4.0 kernel, but did
it really break the HID-USB support also.... that stuff has been working for a
while now.
Oh well, glad to be of some help. (guess I can throw out the cd's I just burnt
<smile>

Kevin Pulliam
kevin.pulliam@telocity.com
Comment 5 Michael Fulbright 2001-02-06 11:49:26 EST
I believe we have addressed this problem internally since the fisher release.

Does the TAB key move the focus around?
Comment 6 Kevin Pulliam 2001-02-06 12:27:37 EST
Your Question,
  "Does the Tab key Move Focus around?"

My Experience,
   No.
Comment 7 Bill Vinson 2001-02-07 09:00:13 EST
Sorry I was unable to respond until now...

The TAB key does not allow me to move around the screen.  Also, the
NUMLOCK and CAPSLOCK keys do not switch on the associated keyboard
lights which I have seen usually associated with a hard hang.

Hope this helps...
Comment 8 Michael Fulbright 2001-02-07 13:37:07 EST
Thanks for the feedback.

Dave do we have one of these for testing?
Comment 9 Ed McKenzie 2001-02-08 21:51:18 EST
I'm seeing this too, and I'm fairly confident it's a kernel bug. 2.2.18pre and
2.4test onward pick up a phantom PS/2 mouse on some motherboards (VIA MVP3?
That's what I have, anyway) and the system freezes if XFree tries to use
/dev/psaux. The effect is similar to yanking a live PS/2 mouse.

Ironically, it was decided on lkml at the time this came up that it wasn't a
showstopper. :)

I can't find a way to turn PS/2 mouse support off in my BIOS. kernel-2.2.16-22
doesn't detect a mouse on psaux unless there's one actually plugged into it, and
the RH7 installer works flawlessly on this box with my USB mouse (also a
Logitech, M/N: M-BD58.) I've been unsuccessful in trying to convince
2.2.18/2.2.19pre/2.4.x that there isn't a mouse there.

Logitech does seem to be a common factor, but it's not so clear this has
anything to do with anaconda.
Comment 10 Bill Vinson 2001-02-09 00:20:07 EST
The odd thing is that I was using 2.4-test 7 or 8 up through 2.4.1 on my
workstation with a USB Logitech mouse and I have never seen this until the
Fisher install...

So, if it was a kernel bug, then I don't see how I missed it.
Comment 11 Ed McKenzie 2001-02-09 01:19:43 EST
RedHat -BOOT kernels have PS/2 mouse support compiled in. I assume you didn't
select this option, since your mouse is USB?
Comment 12 Bill Vinson 2001-02-09 09:02:39 EST
Here is my kernel config for the mice...

CONFIG_MOUSE=m
CONFIG_PSMOUSE=y
CONFIG_USB_MOUSE=m

I still am not sure I believe this is a kernel problem, but I guess we will see
Comment 13 pezz@tkwcy.ee 2001-02-17 18:33:39 EST
I'm seen the same problem here as billvinson@nc.rr.com. I had
never problems with my logitech wheelmouse (oem, m-ub48) before
(from 2.2.x to all the 2.4.0-testXX and 2.4.x kernels). Stopped working
after upgrading from 7.0 to 7.1-beta. Compiled new 2.4.2-pre4 using
kgcc, but no mouse. When X starts up it finds mouse, but I can just
move it. Mouse cursor is situated in the middle on X screen. What I
see weird is that entering cat /dev/mouse and moving mouse doesnt show
any lifesign, so it should be somehow kernel-side problem. Same happens with kernels compiled before upgrading.Could it be
somehow related to tools that are used on startup, like modutils or smth because
after upgrading I've started seeing kernel Oopses from 2.4.0-test10, 2.2.10, 2.4.0-0.99.11 when
loading 3c509 module. 2.2.18 and 2.4.0-test10 never oopsed there before upgrade.
Comment 14 pezz@tkwcy.ee 2001-02-17 19:11:07 EST
I found fix for my problem. As I said I had USB logitech
wheelmouse and as USB mouse it needs hid module to be loaded to work properly.
In Fisher's kernel hid is as module and so gets not loaded when needed.
Comment 15 Brent Fox 2001-02-19 15:50:07 EST
Problems with USB mice appear to be fixed in the latest internal builds.

Note You need to log in before you can comment on or make changes to this bug.