Bug 25671 - No CD-ROM available when installing in expert mode
No CD-ROM available when installing in expert mode
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
Brock Organ
Florence RC-1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 04:33 EST by Walter Mueller
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 15:43:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Walter Mueller 2001-02-02 04:33:35 EST
Booting from CD using an Adaptec 29160 SCSI-Adapter. Hard disk and CD-ROM
are connected to this Adapter. 
Choosing expert mode after booting from CD only offers to install from
harddisk, even if i load then needed SCSI modules. 
Two IDE disks are connected to the second IDE port.
All the disk drives are recognized but not the CDROM.
Text mode installation works fine
Comment 1 Glen Foster 2001-02-02 17:57:46 EST
We (Red Hat) should really fix this before next release
Comment 2 Erik Troan 2001-02-06 13:05:34 EST
Does the kernel find the CDROM drive? Look at the display on VC4 to find out.
Comment 3 Walter Mueller 2001-02-07 13:09:55 EST
When i boot the "Installation Method" menu only offers "Hard drive".
If I press <OK> the "Select Partition" menu shows the partitions on both of the 
connected IDE drives. Now I press <F2> to install the SCSI driver.
After correctly installing the SCSI driver the partitions on the SCSI hard disks 
are also shown in the "Select Partition" menu but going back to the 
"Installation Method" menu still offers only "Hard drive".
VC4 shows that SCSI hard disk and SCSI CDROM are correctly recognized.
Why was the manual selection of the necessary drivers put after the 
"Installation Method" menu ?
In Redhat-7 I first choose the necessary drivers, then the installation method 
and all works fine.

Regards
Comment 4 Erik Troan 2001-02-08 15:36:47 EST
this should be fixed by reverting the aic7xxx driver (done internally)
Comment 5 Brock Organ 2001-02-19 12:52:46 EST
the fisher aic7xxx driver was very troublesome, and has been reverted; verified
aic7xxx sane behavior in qa0217.1 ...
Comment 6 Walter Mueller 2001-02-25 06:36:15 EST
I still can't install wolverine in expert mode because I can't access the SCSI
CD-ROM
In text mode all works fine
Comment 7 Michael Fulbright 2001-02-26 15:42:55 EST
This appears to still be a problem, assigning to an engineer.
Comment 8 Brock Organ 2001-02-26 18:20:50 EST
Walter, 

Using the wolverine CDROM in text, expert mode, I was unable to advance due to
bug 28488 on a test dell poweredge w/aic7xxx hardware ... :(

I was able to select "CDROM" installation method when booting from a floppy with
the boot.img on it ... perhaps this may work for you as well ...?

Using an internal test tree in which 28488 is resolved (qa0226.0), I am able to
select CDROM installation method, then specify the aic7xxx driver and proceed
through the install from there, so this should be resolved ...
Comment 9 Brock Organ 2001-02-26 18:22:45 EST
let me try to be more clear ... :(

> Using an internal test tree in which 28488 is resolved (qa0226.0), I am able 
> to select CDROM installation method, then specify the aic7xxx driver and 
> proceed through the install from there, so this should be resolved ...

the internal test above was booted directly from the cdrom, and not the floppy
:)

Note You need to log in before you can comment on or make changes to this bug.