Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 256781 - Program maps never see changes
Program maps never see changes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.0
All All
medium Severity high
: rc
: ---
Assigned To: Ian Kent
Brock Organ
: Regression, Reopened
Depends On:
Blocks: 425909
  Show dependency treegraph
 
Reported: 2007-08-27 11:44 EDT by Ian Kent
Modified: 2008-05-21 10:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0354
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:37:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0354 normal SHIPPED_LIVE autofs bug fix and enhancement update 2008-05-20 08:52:25 EDT

  None (edit)
Description Ian Kent 2007-08-27 11:44:34 EDT
Description of problem:
Program maps in autofs version 5 are never removed from
the internal cache and so program map changes aren't seen.

Version-Release number of selected component (if applicable):
All versions of autofs version 5.

How reproducible:
Always

Steps to Reproduce:

Create a program map /etc/auto.prog as:
#!/bin/bash
echo "lookup of \$1" >> /tmp/bug.tmp
echo localhost:/export/doesnotexist

Add the line
/test   /etc/auto.prog
to /etc/auto.master.

Execute:
stat /test/foo
sleep 65
stat /test/foo
sleep 65
stat /test/foo
  
Actual results:
Only one entry of "lookup of foo" ever gets logged to
/tmp/bug.tmp.

Expected results:
The entry should be logged three times unless there is
a timeout mechanism on mount failures in which case only
the number of entries allowed by the timeout of failures
should appear in the file /tmp/bug.tmp.
Comment 2 RHEL Product and Program Management 2007-10-02 03:54:27 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 7 errata-xmlrpc 2008-05-21 10:37:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0354.html

Note You need to log in before you can comment on or make changes to this bug.