Bug 256981 - Can't use Qlassik font
Can't use Qlassik font
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gtk-qt-engine (Show other bugs)
7
All All
medium Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 12:12 EDT by Mary Ellen Foster
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 12:31:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 12179 None None None Never

  None (edit)
Description Mary Ellen Foster 2007-08-27 12:12:57 EDT
Description of problem:
This is actually pretty weird. I was playing around with fonts under KDE and
decided to use Qlassik (http://www.dafont.com/qlassik.font) as my UI font. This
works fine with KDE -- however, Gnome apps like Firefox and Eclipse just used
the default sans-serif font, in the size I'd specified for Qlassik. Yes, I did
restart KDE multiple times and try changing configuration options: whether I say
"use KDE fonts" or "use this specific font", Qlassik won't work.

Weirder is, if I use Gnome's own font configuration tool, I am able to choose
Qlassik.

I thought this might be because the fonts are *.otf instead of *.ttf, but I
converted them to .ttf and had the same problems.

Version-Release number of selected component (if applicable):
gtk-qt-engine-0.70-4.20061211svn.fc7

How reproducible:
Always

Steps to Reproduce:
1. Choose Qlassik as the KDE font
2. Tell gtk-qt-engine to use the KDE font

  
Actual results:
Gnome apps use a default sans-serif font in the correct size

Expected results:
Gnome apps use the specified font

Additional info:
Comment 1 Rex Dieter 2007-08-27 12:24:19 EDT
odd indeed.  Be aware, afaik, that freetype currently doesn't include full
support for otf yet.

I'd suggest trying submitting this upstream, as I doubt there's much we can do
about this:
https://bugs.freedesktop.org
Against "GTK-Qt Engine"
Comment 2 Mary Ellen Foster 2007-08-27 12:31:39 EDT
Okay, done.

Note You need to log in before you can comment on or make changes to this bug.