Bug 25730 - devfsd kernel missing modules.devfs
Summary: devfsd kernel missing modules.devfs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-02 16:42 UTC by Eric Sandeen
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-02 16:42:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Sandeen 2001-02-02 16:42:18 UTC
(Didn't see a devfsd option in packages, so I'll assign this to kernel
since it comes from the kernel SRPM)

The devfsd package is missing /etc/modules.devfs which is needed for module
autoloading.

Suggested patch for the 2.4 kernel spec:

--- kernel-2.4.spec.orig        Thu Feb  1 16:34:28 2001
+++ kernel-2.4.spec     Thu Feb  1 16:35:22 2001
@@ -686,6 +686,7 @@
 install -m 755 -s devfsd/devfsd $RPM_BUILD_ROOT/sbin/devfsd
 cp -p devfsd/devfsd.8 $RPM_BUILD_ROOT%{_mandir}/man8
 cp -p devfsd/devfsd.conf $RPM_BUILD_ROOT/etc/devfsd.conf
+cp -p devfsd/modules.devfs $RPM_BUILD_ROOT/etc/modules.devfs
 
 make -s clean -C $RPM_BUILD_ROOT/usr/src/linux-%{kversion}/devfsd
 
@@ -952,6 +953,7 @@
 /sbin/devfsd
 %{_mandir}/man8/devfsd.8*
 %config /etc/devfsd.conf
+%config /etc/modules.devfs
 
 %files headers
 %defattr(-,root,root)

Comment 1 Michael K. Johnson 2001-02-08 21:20:57 UTC
Fixed in our source tree on Feb 1, should be in all kernels built
later than that.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.