Bug 257481 - Kernel 2.6.22 breaks ACPI wakeup
Kernel 2.6.22 breaks ACPI wakeup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All All
high Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 15:00 EDT by Ville Skyttä
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.22.9-91.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 16:18:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (23.41 KB, text/plain)
2007-09-30 10:09 EDT, Ville Skyttä
no flags Details
lspci -vvxxx output (44.53 KB, text/plain)
2007-09-30 10:10 EDT, Ville Skyttä
no flags Details

  None (edit)
Description Ville Skyttä 2007-08-27 15:00:59 EDT
Kernel 2.6.22 breaks ACPI wakeup for me on 2 pretty much completely different F7
boxes, both fully up to date.  /proc/acpi/alarm is gone, and after googling
around I found out that /sys/class/rtc/rtc0/wakealarm should apparently be used
instead of it.  However, it does nothing.  For example:

# echo 1188327381 > /sys/class/rtc/rtc0/wakealarm
# cat /sys/class/rtc/rtc0/wakealarm
(no output)
# echo 1188327381 > /sys/class/rtc/rtc0/wakealarm
# echo 1188327381 > /sys/class/rtc/rtc0/wakealarm
(without echoing 0 in between there this should apparently have errored out, but
does nothing either)
# echo 0 > /sys/class/rtc/rtc0/wakealarm
(nothing)

There's no output, and no messages in syslog, same thing on both boxes.  In <=
2.6.21 kernels ACPI wakeup with /proc/acpi/alarm worked just fine with both. 
One box has Abit TH7-II RAID motherboard with a P4@1.6GHz, the other ASUS A8N-VM
CSM mobo with a AMD64 3200+.
Comment 1 Chuck Ebbert 2007-08-28 16:04:54 EDT
Do any of the other fields show data, like /sys/class/rtc/rtc0/time ??
Comment 2 Ville Skyttä 2007-08-28 16:45:36 EDT
Yes, eg. /sys/class/rtc/rtc0/{date,time} show correct things on both boxes.

BTW, the box with the Abit mobo is currently running 2.6.22.4-65.fc7 and the
ASUS one is still at 2.6.22.1-41.fc7 (because of 2.6.22.4-65.fc7 bcm43xx
problems, but that's offtopic here).
Comment 3 Ville Skyttä 2007-09-25 15:06:47 EDT
Still broken in kernel-2.6.22.7-85.fc7
Comment 4 Christopher Brown 2007-09-30 09:05:18 EDT
Hello Ville,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

Can you attach a dmesg output as test/plain as well as lspci -vvxxx which might
help the relevant maintainer (who I will assign this to) track down the issue a
bit quicker. If there is a chance you can test with a rawhide kernel as well
that would be great.

Cheers
Chris
Comment 5 Ville Skyttä 2007-09-30 10:09:22 EDT
Created attachment 211751 [details]
dmesg output

Here goes the dmesg output.

From kernel-2.6.22.9-91.fc7's changelog: "- Revert to old RTC driver."

Apparently because of this, the good old /proc/acpi/alarm is back and works
again as it always used to, and there's no /sys/class/rtc* any more so I cannot
test the previous problem with the new rtc stuff with this kernel nor really
upgrade the boxes I have available to a Rawhide kernel at the moment.
Comment 6 Ville Skyttä 2007-09-30 10:10:34 EDT
Created attachment 211761 [details]
lspci -vvxxx output
Comment 7 Christopher Brown 2007-09-30 11:35:53 EDT
(In reply to comment #5)
> Created an attachment (id=211751) [edit]
> dmesg output
> 
> Here goes the dmesg output.
> 
> From kernel-2.6.22.9-91.fc7's changelog: "- Revert to old RTC driver."
> 
> Apparently because of this, the good old /proc/acpi/alarm is back and works
> again as it always used to, and there's no /sys/class/rtc* any more so I cannot
> test the previous problem with the new rtc stuff with this kernel nor really
> upgrade the boxes I have available to a Rawhide kernel at the moment.

Okay Ville, thanks for the feedback. If you can update this when a stable 2.6.23
arrives I'll take another look at it.

Cheers
Chris
Comment 8 Chuck Ebbert 2007-10-01 16:18:11 EDT
/proc/acpi/alarm is back and should work fine. Fedora 8 Test 3 has reverted to
the old driver as well and should also be fine.

Note You need to log in before you can comment on or make changes to this bug.